Caching, freezes and sound stuttering on movies over Smb & NFS

I would have if I could. I have no screen at my disposition that could be moved close to the router and have no idea as to how I could test video playback without a screen.

I use the integrated WiFi chipset of the Rpi 3. Internet streaming is very smooth with fast caching.

The built-in WiFi on RPI3 has been reported as not great by some people.
If you have a spare USB WiFi device you could try that just to prove things.

I’ve tried with a WiFi dongle I have here, it was worst. Mind you it is an old one.

Is there maybe some tuning up I could do to kodi (I don’t know buffer or something like that? ) or to the samba share to get better performance. If my mac computer can read the files flawlessly, this should be possible on the pi too, or I m totally wrong?

Try mounting the samba share via fstab to /mnt/<your.share>

Then, assuming you’ve already added the previous samba location as a source in Kodi, simply edit that source to point to the new mount.

Thanks! It is WAY better now!

However, on reboot I have an error: unable to mount /mnt/samba and I need to do a sudo mount -a to work that around. Any explanations on this?

I’ve just added “//share/dir /mnt/myshare cifs username=user,password=pass” to fstab was it the good way to do it?

Make sure you are using IP address rather than hostname and also try passing these flags in the following example.

// /mnt/Video cifs noauto,x-systemd.automount,username=osmc,password=osmc 0 0

Might be a stupid question but in your example where do I put the user and pass for the access to the share ?

(thanks for your answers btw , that’s really helpfull)

I’m not sure what you mean? You have shown your example as below, my example will follow:
//share/dir /mnt/myshare cifs username=user,password=pass
// /mnt/Video cifs noauto,x-systemd.automount,username=osmc,password=osmc 0 0

I’m not suggesting to use the line I’ve provided as an example. My previous suggestion is actually to also use the noauto,x-systemd.automount options in your fstab line. Remember, format and spacing is important here. No spaces, only commas between the options.

Ok it was just a misunderstanding. I thought that in your example username and password were related to the default osmc user in your example while we were both talking about the user for the share. I am a real beginner sorry.

Well, your options do work ! Thanks! So basically what does it do? It does not mount at reboot but when? Anyways seems fully functional now ! Thanks a lot.

@DBMandrake explains much better than I can :wink:

5 posts were split to a new topic: “a stop job is running” for samba unmount

Hi, I think i encounter the same problem with my smb-wifi sharing. For small files (<1Go) it works, but It’s awful with a 2-3 or 4 Go file : impossible to watch the movie properly !
It’s not a problem of my wifi because when I stream films over the internet, it works fluently (even for 1080p sources) !
So please, @th0m or @DBMandrake could you detail what you did to solve the problem ? Where do I put the lines above ?
Thanks !

Follow this wiki to mount via fstab

Thanks for your link that I have followed yesterday. I have no error at any moment but when I test cd /mnt/Videos (the name I have chosen for the share), I can read « no such device » therefore I cannot access to the share.
My « server » is a hard drive connect to my internet box. I think I make no mistake with the IP but I’m not sure about the password since I normally access to it as Guest (no login/pwd) on my Mac for example.
In the example, how is the shared folder « videos » defined in OSMC ?
Is there a way to show you exactly the issue or my local settings ? Thanks again. Pierre

You can try to remove password and use username guest but generally that is not supported by this method. So suggest that you check your internet box.
Alternatively why not move the harddisk from the internet box to the Pi and share from there?

You mean that you think that it is just a password matter as I describe the issue ? I have to try the options "username=guest, password=, " if I understand you well ?

I think I can’t easily move the hard disk since my Pi is on the ceiling connected to my video projector. And plus I use the same hard drive to broadcast music to my internet gateway… BUT maybe that you’re trine to tell me is that it’s possible to use the Pi to to this ? Upnp share ? And how to access to the HD from my Mac of iPhone in that case ?

Well not sure on your orginal issue but for now you can try to change those values but would suggest to check on the internet box to create that users.

Yes you can install the Samba Server from the OSMC app store that would allow you to share the drive from the Pi similar to your internet box. That would then also be reachable by Mac and Iphone.

DLNA/UPNP is another option but samba is recommended

I would suggest to plug the hard drive in the pi too. II’d say that’s the only way you will get a smooth experience watching movies on your pi. You asked how I solved my problem… I bought a 5.0Ghz WiFi dongle. The integrated WiFi often won’t be sufficient to handle HD streaming over WiFi, all the more in a crowded place (don’t know if it is your case).

As for your questions, OSMC be easily set as a samba server so you’d get exactly the same functions.

I’ve rapidly tried to connect the HD directly to the Pi and switched the smb app option on.
I had no access on the mac to the HD : i can see the share in the finder, but that’s all… An idea to tell you more about my problem ?

Well grab-logs -A is always the first step of troubleshooting.