Caching videos

I have OSMC installed on a raspberry Pi. There used to be an add on tool that would create the advancedsettings.xml file and activate a cache so you could start a video pause it and let it load in for while. is their any way to still d o that?

Hi,

I’m not aware of this addon, but if you advise which pi model you have; I can advise on recommended settings and how to add via the commandline.

Thanks Tom.

It was called “Easy Advanced Settings” and I’m not even sure if it is available any more. It was actually never updated for the changes to Kodi 17 in terms of the names of the settings for the cache size, read-factor etc. So I imagine it is no longer in development.
So the best thing for OP to do is to create the file manually.

It’s a raspberry pi 3

Create a file called advancedsettings.xml and inside place the values you want to use.
Here is the file I use which hasn’t led me astray on a Pi3B / 3B+

<?xml version="1.0" encoding="utf-8"?>
<advancedsettings>
	<gui>
		<algorithmdirtyregions>1</algorithmdirtyregions>
		<nofliptimeout>0</nofliptimeout>
	</gui>
	<fanartres>720</fanartres>
	<imageres>540</imageres>
	<video>
		<busydialogdelayms>750</busydialogdelayms>
		<playcountminimumpercent>101</playcountminimumpercent>
	</video>
	<samba>
		<clienttimeout>30</clienttimeout>
	</samba>
	<cache>
		<memorysize>125829120</memorysize>
		<readfactor>8</readfactor>
		<buffermode>1</buffermode>
	</cache>
	<splash>false</splash>
</advancedsettings>  

This file is then placed in /home/osmc/.kodi/userdata/
Do this, then reboot.
This will give you a run-ahead video cache of 45MB.
*Edit: some of these settings may not suit your needs such as the playcount. I have it set so nothing gets marked as watched. The cache settings, however, should be just what you need.

Hi,

The cache settings ColumbosCoat suggest should work find, although I’ve never found the need to have the readfactor higher than 5 and I also have a slightly bigger memory size; these are the settings I use:

<advancedsettings>
	<cache>
		<memorysize>157286400</memorysize>
		<buffermode>1</buffermode>
		<readfactor>5.0</readfactor>
	</cache>
</advancedsettings> 

To make these changes you will need access to the command line:

https://osmc.tv/wiki/general/accessing-the-command-line/

Then use a text editor such as nano to make create the file:

nano ~/.kodi/userdata/advancedsettings.xml

Ctrl+x and yes to save.

Then reboot, should be good then.

@ColumbosCoat your cache is 125MB not 45MB

Thanks Tom.

Yeah for the read factor I just doubled the default. Seemed like a good number to go with.
As for the cache, yes I know it is using 120MB of RAM. 125,829,120 / 1024 / 1024 = 120.
I believe this is split for 45MB video / 45MB audio “run-ahead” cache and the remainder as a prior buffer held in RAM for rewinding etc.

1 Like

Hi,

You are indeed correct, I’d forgotten kodi split the video and audio buffer equally.

Regards Tom.