Can anybody recommend a decent gigabit usb adaptor?

Hi,

I’ve just bought this adapter ( Anker | USB 3.0 to Gigabit Ethernet Adapter) and plugged it in and it doesn’t appear to be plug and play for me. When connected by lan normally I have a manually configured fixed ip address. Can you tell me do I need to disable that please? What settings do I have to set using the MY OSMC program? I have ethernet enabled. I’ve tried disabling and that doesn’t work…

Thanks for any help you can give me

-Mat

Is the fix IP address configured on the Vero or on the Router (DHCP server)?

The router’s DHCP server maps MAC addresses and IP addresses. Since the USB-Ethernet-adapter has its own MAC address the router does not recognize it. You have to use the MAC address of the adapter instead the MAC address of the Vero for the “old” IP address.

It’s in the Vero setup for the built in ethernet adapter.

Should I turn that off? Will it then recognise the usb-ethernet adapter?

Thanks

-Mat

@mlavende: I assume you want to replace the 100 Mbit/s Vero 4k LAN interface with the USB-Giga Ethernet adapter, right?

I do not know whether this adapter will be recognized by the Vero 4k at all but also let’s assume this is the case:

  1. Shutdown the Vero 4k until the red light
  2. unplug the power cable
  3. insert the usb-adapter into one of the Vero 4k USB ports or powered USB hub
  4. Switch the LAN-cable from the Vero’s LAN port to the USB-Ethernet adapter … the LAN port of the Vero is now empty!
  5. Power on the Vero this could take a while
  6. Go to MY OSMC -> Network > Wired
  • in case the adapter was disabled -> enabled it
  • in the status line of the menu you should see something like usbnet0 … if you see eth0 something is wrong, most possible the adapter was not recognized at all
  • if you see usbnet0 or so, you can now enter manually your fix IP address data … and finally try a reboot

If that should not solve your issue, please, open a new thread since this thread cares about recommended Gigabit usb adapters and not troubleshooting an Anker USB-Ethernet plug.

1 Like

Thanks JimKnopf I’ll try that later

I was under the impression that I bought a recommended USB adapter. It seemed to be recommended by Rito_Bear earlier.

-Mat

also thanks to JimKnopf!

Just to ensure mlavende: I have exactly the same Anker-adapter and if you follow Jim’s guidelines there shouldn’t be any problems.

Thanks to you both. I tried it again and still no dice until I manually configured it to use the same IP address as when the lan cable was plugged into the standard Ethernet port. Once I’d done that it worked fine.
Two points though. It shows as eth1 rather than usbnet and the lights on the adapter don’t change colour to show connected or data transmission.
Either way I’m very happy though thanks. Just tried a 4k 120mb/s demo that previously stuttered and it was smooth all the way through.

I’ll leave you alone now

Thanks again
-Mat

1 Like

I also bought the Anker USB Gigabit adapter.
I configured the MyOSMC panel with fixed IP, but how do I know if it’s working at full 1000 speed instead of just 100?

Two options

  1. Check with ethtool the interface speed
  2. Use iperf3 to check speed against another machine

It doesn’t reach full GE, just about one third of it (see here).
Either iperf (search the forum, there are dozens of posts how to set it up) or a quick test via FTP with one big .iso. Either way, bitrates higher than FE for simply playing a video file are only needed in a very small number of cases. Heck, even the UHD Blu-ray remux of John Wick: Chapter 2 with its insane bitrate plays smoothly on the Vero 4K mounted via NFS.

I hope to reach high speeds because in my setup the media disk is connected to the Vero and I transfer media through LAN.
and with 100 it’s painfully slow to transfer even a single hi quality 1080 episode around 5-7GB, let alone 4K movies of 70-80GB – it takes soooo much time

So you’ve got a HDD attached to the Vero via USB? Then I understand the problem. The solution for the scenario without a NAS from which to stream is to let the playing device also download the content it plays instead of downloading that stuff with a PC and then transferring it to the Pi/Vero. You can add any program for downloading to OSMC, e. g. transmission for torrents.

1 Like

thanks but not very practical for me. hardly using torrents lately…

What’s your go-to then? NZB? DDL? FTP? OCH? Mega? You can automate (almost?) all of them.

Is NZB still alive? Didn’t Morganelli render it useless with his en masse DMCA requests?

Still use it daily… so for sure not dead!

According to Wikipedia, it’s not.
I should’ve just written “usenet binaries” instead. Until now, I didn’t know it was also a service but not only a format.

Now I’m confused.

Newzbin isn’t NZB, usenet binaries are commonly used.

I thought the automated takedowns completely killed it.

Sam

That is what happens before, but there are ways around it, nzbfinder.ws collects all based on metadata… haven’t had any issues I must say.