Can I "normalize" AAC 5.1 volume?

Hi, I have several AAC 5.1 coded movie files (and Kodi is set to 5.1 output). I have tested my hardware setup with some Fraunhofer AAC 5.1 demo files and it seems my Yamaha receiver can (or does) output 5.1 AAC files all right.

However the volume is (compared to pass-through DD 5.1 or DTS) sooooo incredibly low that I have to go to the audio menu of the file and increase the volume amplification. But this setting will be on a “per file” basis only. Can I enable this “amplification” for all AAC encoded files? I believe if I enable “set as default for all media” this will mean that also my pass-through files will be amplified.

I am aware that this is a luxury problem, but is there a way to sort of “harmonize” the “non-passthrough” volume to the standanrd volume of the passthrough tracks?

I hope I expressed myself clearly. Many thanks for your support.

PS: I have a Vero4K+ with HDMI connected to my receiver



My understanding is that the opposite is true. If you “set as default for all media”, it should only affect affect audio which isn’t passed through. With pass-through audio is passed to the receiver untouched.

When you play a video with a codec which can be pass-through (dts for example), under sound options (if pass-thorough is enabled); volume and amplification is greyed out. As they can’t be adjusted.

I suggest setting amplification as required and setting as default, and testing with non-pass-through and pass-through. If you are not happy with the results, you can always revert.

Alternatively you could try enabling “The Night Listening Mode” on the Yamaha, this should at least beef up the speaking track.

Thanks Tom.

1 Like

Instead of setting Kodi to 5.1 channels try setting it to 2 and enabling the AC3 transcode option in the passthrough section. This may get you to where you want to be without the rest of the mucking about.

Alternatively you might check your AVR settings when playing LPCM audio. It may be that your AVR maintains separate audio settings for that Kind of input and you just need to adjust it to make it the same as your passthrough formats are setup.

1 Like

That of course did the trick. Many thanks

1 Like