Can I use Netflix on OSMC?(post 4)


Great, ill keep my eye out for your response. Until then I’ll look into inputstream.


Clean install of Leia -328 (329 was publish during install process) and Netflix-add on. had to manually installed the dependencies as per post 142 in this thread.

After I’ve logged in to netflix, i choose m,y profile navigated to a show i’m currently watching, clicked play and then i got the friendly inputstream.helper, let it run and voila the episode started. There was a new dependency: script.module.addon.signals. But i’ve edited post 142 to reflect it.


Did a clean install and followed the posts near post 142. Everything was working. Discovered the real problem was I use Nordvpn and was using openvpn to connect on start up and netflix was blocking the connection. Appreciate the help as I was having trouble with other dependencies and got those addons to work as well.


Is it capped at 720p?


Since it’s software decoded, none of the OSMC-devices i’ve tested can do 1080p. I got it set on 480p on my pi2 to make sure it’s fluid all the time.


Hi Joakim,

Where did you set it to 480p? Is that the max resolution general decoder or the secure decoder, or both, in the inputstream addon settings?



Mixed feelings after latest updates.

  • finally there’s a button to skip the intro - great!
  • gosh, those subtitles don’t show up again…

Really strange. I have checked it with The altered carbon, Disenchantment - no subs. But with The Titan is’t ok… However it is all fine with Win10 app… I see no Netflix related errors in the log, just regular bunch of lines after the stream playback is started.


Just made fresh install of osmc and updated kodi to v18.
installed netflix and all add-ons dependency.
but netflix add-on always closes leaving the error in kodi.log:

20:05:58.532 T:1472197360   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ImportError'>
                                            Error Contents: No module named inputstreamhelper
                                            Traceback (most recent call last):
                                              File "/home/osmc/.kodi/addons/", line 12, in <module>
                                                from resources.lib.Navigation import Navigation
                                              File "/home/osmc/.kodi/addons/", line 28, in <module>
                                                from resources.lib.KodiHelper import KodiHelper
                                              File "/home/osmc/.kodi/addons/", line 17, in <module>
                                                import inputstreamhelper
                                            ImportError: No module named inputstreamhelper
                                            -->End of Python script error report<--
20:05:58.569 T:1480585968   ERROR: GetDirectory - Error getting plugin://
20:05:58.570 T:1917624320   ERROR: CGUIMediaWindow::GetDirectory(plugin:// failed

Any help will be greatly appreciated.


you tube is also failing: it seems I should not heve updated to kodi 18 in a fresh install before installing some basic add-ons in kodi 17.


@mark71 I’ve set it up in both, that’s the only change I’ve done in inputstream settings


@nvdias Looks like inputstreamhelper add-on wasn’t installed (the bit which downloads and installs the newest libwidvine)


yeah. but this is a fresh install.
I’ve downgraded rbp2-medacenter-osmc to 17.6.0-49 (kodi 17).
installed youtube add-on
and back to kodi 18.
netflix installed and now it doesn’t complain about inputsctreamhelper.
but about AddonSignals …

I’m almost sure it is because i’m in a fresh system, that somehow netflix plugin cannot force the installation of dependencies.
I will now try with an image from a configured kodi 17 system


OK so does anyone know how to logoff from the netflix app and login with a different user?


Do you mean a different account or profile. On mine it’s asks which profile on each reboot. Not sure about account but I imagine you might have reinstall the addon.


If you go to the add on’s settings, under Account, you have the option to switch accounts or logout.

Have you enabled auto login for your preferred profile? If you choose your preferred profile and press the context menu button, you should be given the option to automatically login using that profile.

Thanks Joakim, I wasn’t entirely sure which one I needed to change.


Capped it at 720p on my Vero4K. 1080p sometimes works; with 720p no problems so far.


all working. this is great: having netflix finally at real 23.976fps !
No more crappy 60 fps juder.

It was just a question of satisfying the netflix missing add-ons: thanks @joakim_s


I am using OSMC on Raspberry Pi with 16GB SD card, and when I installed Netflix add-on it asked me to install Widevine update, 1.9GB, but then always said not enough disk space. The only way I could get it to work was to use Gparted to move the ext 4 partition to the end of the card, then resize the FAT partition previously just over 200MB to 5GB. The Widevine update will only download to the FAT partition. Is there any other solution? Is there any fix going to be applied to OSMC to make the FAT partition large enough by default?


I doubt that Widevine alone would be 1.9GB ,i guess other stuff involved

The FAT partition is mounted at /boot, there is no logic via widevine would download to that location.


The Widevine update only comes in a Chrome Recovery Image which is 1.9GB. All I can say is what I did works, and it does appear to download to the FAT partition. I did not change the size of the ext4 partition, and the rest of the disk is unallocated, so I think it must download there.