[HOW-TO ALL PLATFORMS]Can I use Netflix on OSMC?(post 4)

Hi guys,
I’ve never consider Netflix since couple of days before when a firend of mine told me about it… :slight_smile:

I’ve installed OSMC (VERSION_ID=“2017.10-1”) on my Raspberry, can I use Netflix on it? If yes how to do it in the best way?



I recently incorporated Netflix and Amazon into my RPi3 following the instructions outlined here: RPi streaming station with Amazon Instant Video and Netflix | laclaro

I’ll give it a try thanks!

Here is a small guide for Pi 2, 3 and Vero4k, remember Netflix addon is still under development:

First make sure your system is up to date:

sudo apt-get update
sudo apt-get dist-upgrade

I always reboot after a dist upgrade, since there can be upgrades that night need it, like kernel updates.

After reboot start a new ssh session and run these commands:

wget https://raw.githubusercontent.com/zjoasan/netflix-install-script/master/netflix_prep_install.sh
chmod +x netflix_prep_install.sh

If you dont want to use the script here comes the manual steps:

Crypto for netflix plugin(for Kodi 18)

sudo apt-get install python-crypto
sudo apt-get install build-essential python-pip
sudo pip install -U setuptools
sudo pip install wheel
sudo pip install pycryptodomex

(for 19.x)

sudo apt-get install python3-crypto python3-pip python3-pycryptodome

Getting netflix-repository .zip

wget https://github.com/castagnait/repository.castagnait/raw/master/repository.castagnait-1.0.1.zip
wget https://github.com/castagnait/repository.castagnait/raw/matrix/repository.castagnait-1.0.0.zip

In Kodi:

goto Settings
choose Add-on browser
choose Install from zip file
navigate to homefolder (homefolder/addons, if you used the script)
choose repository.castagnait-1.0.1.zip
Return to the add-ons browser and choose Install from repository
then select CastagnaIT repository and install Netflix add-on
go back to main menu
goto Video->Video add-ons
If you dont have netflix there, go to my addons, video-addons, netflix and enable.
First time you start Netflix it will ask you for your login credentials. Here you might have to go authkey solution. but that’s abit out of the scope of this script.
When you first start a video in netflix plugin, it will notice you dont have libwidvine installed and help you install it. (takes a while, will download an image and extract the latest liwidvine, and install it. Let it run as root, when it asks)

For Pi’s you got to run in MMAL, omxplayer will not work.
There is a patch that hasn’t made it to the addon yet that disables omxplayer before addon start and enables it after addon exit.

You might need to restart your OSMC device after installation.

Edit: Added Libwidevine extraction bit
Edit 2: Updated install procedure to reflect the OSMC-v18-alpha skin
Edit 3: Plugin now extracts libwidvine by it self, no need for extraction script.
Edit 4: Added an automation script.
Edit 5: Removed instructions for v18 nightlys.
Edit 6: Changed the version requirements for pycryptodomex, and changed the download to netflix-repository, defaults to Kodi v.18 addon, remarked Kodi v.19 in script.
Edit 7: rewrite the instruction to match current OSMC stable
Edit 8: rewrite the instruction to match current OSMC stable again



I was able to make it work on my Rpi 3.

However, on Stretch, my Hifiberry Digi+ stopped working.

There was some changes in Leila build, which gmc is on top of

1 Like

Hi all, thanks for the guide.
I was able to install and log in to my netflix account without a problem.

The issue is video playback, which does not work. After selecting a movie or an episode, the screen just stays black.
Here is the link to my logs, obtained with grab-logs -A.

I think the problem is the one below.
17:24:09.155 T:1215390464 INFO: Output - renderer not configured

Do you have any idea how to solve this problem?

[EDIT] I was able to finally make it work. The problem was the hardware acceleration of omxplayer. Disabling it made my RP3B work like a charm.
Again, thank you so much for this guide

followed your guide on a Vero4K. installation only complained about 2 addons missing (streaming.adaptive and pycryptodome) but installed anyway.
Logged into Netflix and played an episode without issues.

Only “issues” I have seen (but might be related to my skin not configured yet) is that I could not differentiate between played and unplayed episodes and my favourite skin (Mimic) not yet available for Leia.



I have problem with opening of Pacific Rim on Netflix, on Raspberry Pi 3. I tried to turn off accelerations. I even tried other distributions. OSMC is starting the movie and then I can see a sad face and the system is rebooting. I’m waiting for all clues. I have not seen this problem at other films yet. I’m waiting for any clues.

Logs would be a great start.

Here it is:
Should I send you something else?

It can have some errors with bootloader because I use berryboot.

I’ve followed the tutorial in the laclaro link, as well as the concise version posted by Joakim. I’m able to get to the install screen for the add-on from the repository, but I am getting this error message:
the dependency on script.module.pycryptodome 3.4.3 could not be satisfied

The one step I haven’t been able to figure out is installing Stretch. However, I’m running an up-to-date version of OSMC, and am not sure if a Stretch install is necessary.

I’ve attempted to install the add-on from version 12.7 to 12.0 and the error message is the same with all versions. I’m on a RasPi 3.

any suggestions would be much appreciated!

Stretch is required to install latest Kodi version from GMC so that would be recommended if you want to test Netflix

The error message is “normal” and can be ignored if you have followed successfully all steps from @joakim_s

Does this mean you can’t play the file in any distribution? If so, then it’s not a OSMC problem. I’d suggest the Kodi forums for help.

I’ve installed Stretch following the instructions posted above, but I am unable to find Netflix in the addon browser. The error message is also still appearing after I attempt to install. Should I uninstall everything and start over, or am I missing something?

Have you read the instruction above?

Yes, I have. After installing stretch Netflix is now enabled in the addon repository, but does not appear in Videos > addons

I’ve rebooted a few times, and it’s still a little ghost :ghost:

Would it make sense to uninstall everything, delete the zip and start again?

I would send the logs to the developer of Netflix addon.

23:46:54.549 T:1417671424 WARNING: Invalid media type ""

This could indicate the stream the plugin tries to stream is incorrect.

Hi there, thought I’d try one more time to see if anyone has had a similar problem. I am unable to install the Netfilx plugin. I am running OSMC on a RasPi3. I have installed Stretch. I have followed all of the instructions detailed by Joakim_Sandstrom at the top of this post.

When I go to
Settings>Add-on Browser>Install from repository>Netflix Addon Repository>Video add-ons>Netflix
I am given the option to Install. However, no matter what version I select to install I receive an error message that the dependency on script.module.pycryptodome version 3.4.3 cannot be satisfied.

The add-on is not visible in Videos>Video add-ons, which suggests that it has not been installed at all.

My pycryptodome repository is 3.4.7. Can this be causing the problem?

Can anyone point me in the right direction as to what needs to be tweaked? I have an up-to-date version of Kodi.

I say click ok on dependency page since kodi doesn"t see them even if they are in the system.

Mobile rigjt now but will check logs later.