RPi 3 B, Kodi 18, Addons do not install from repository


#1

Hello, new here.
Today I’ve set up my brand new RPi with OSMC and followed this guide to get netflix to run: Can I use Netflix on my Raspy OSMC?

Wonderful guide, worked almost perfectly. As a result, I upgraded to kodi v18.

Now, I have very similar problems to the person in this topic: RPi2 with RC2 and 3: Add-Ons not downloading (NOT a DNS problem) [solved] in that I can’t install addons via the Kodi gui: Kodi almost instantly shows the message “failed to install”, but I can go into kodi.log, find the link it’s trying to download, and wget it manually, then install via zip.
Here’s the kodi.log lines for reference:
ERROR: Requested path http://download.osmc.tv/kodi/addons/krypton/plugin.video.youtube/plugin.video.youtube-5.5.1.zip not found in known repository directories 15:19:41.358 T:1800393440 ERROR: CAddonInstallJob[plugin.video.youtube]: failed to resolve addon install source path
Except my problems seem to deviate at the point where they find the solution, which was slow DNS resolving. I’ve performed this command:
LANG=C wget --server-response --timeout=2 --max-redirect 0 --spider www.google.com
and got this response:

--2018-05-07 15:47:01--  http://www.google.com/
Resolving www.google.com (www.google.com)... 216.58.207.68, 2a00:1450:4002:807::2004
Connecting to www.google.com (www.google.com)|216.58.207.68|:80... connected.
HTTP request sent, awaiting response...
  HTTP/1.1 200 OK
  Date: Mon, 07 May 2018 13:47:01 GMT
  Expires: -1
  Cache-Control: private, max-age=0
  Content-Type: text/html; charset=ISO-8859-1
  P3P: CP="This is not a P3P policy! See g.co/p3phelp for more info."
  Server: gws
  X-XSS-Protection: 1; mode=block
  X-Frame-Options: SAMEORIGIN
  Set-Cookie: 1P_JAR=2018-05-07-13; expires=Wed, 06-Jun-2018 13:47:01 GMT; path=/; domain=.google.com
  Set-Cookie: NID=129=WnlFPop61eL_m0GFR0nyb3pKTQfYQ3I7tGaBfzI1q6TcAyFK6LT5-RbgsLcdO7t9W9dL1ln2KCwjHe3HPLIWJXlePhwfuQq2o9e04Thue9tZvIkw1m5RDWiaVJvvzppt; expires=Tue, 06-Nov-2018 13:47:01 GMT; path=/; domain=.google.com; HttpOnly
  Transfer-Encoding: chunked
  Accept-Ranges: none
  Vary: Accept-Encoding
Length: unspecified [text/html]
Remote file exists and could contain further links,
but recursion is disabled -- not retrieving.

which to my eyes looks fine. Plus, the fact that I don’t have a delay after trying to install tells me it’s not a timeout like in the link given.

Now, I may be wrong, maybe it is a DNS issue after all. I’d rather not switch to a different DNS, but if that’s the solution then I guess I’ll have to go for that.


Skin.helper.service errors on VERO4K+
Can I use Netflix on OSMC?(post 4)
#2

grab-logs -A would provide more relevant info that may give us an indication of the problem.


#3

Since I managed to install the addons manually via .zip, I’ve just tried to grab another addon, hoping to generate relevant logs. here’s the link:

https://paste.osmc.tv/abexepekec

the addon I tried to install is arte tv, I found some entries via ctrl+f “arte_tv” (as arte is part of “started”, it’s not useful to ctrl+f that =p )

I hope this helps! (Sorry for not providing this log earlier, I should’ve googled how to obtain these log links… )


#4

Hi all,

i have the same issue…i can’t install any addons from repository only manually via .zip

https://paste.osmc.tv/tunoveyoga

do you know a solution for the issue ?

Br
boxi


#5

Any update on this? Im having the same issue new install from today.


#6

We didn’t get a lot of traction on this – can you post a log?

Sam


#7

all the logs really show is this

10:37:20.637 T:1484780272 ERROR: CAddonInstallJob[plugin.video.abcfamily]: failed to resolve addon install source path

happens to any video addon I try


#8

Correction on all addons


#9

Backup and delete the .kodi directory inside /home/osmc and reboot. A new .kodi directory will be created, but you have to setup everything again from scratch. Now installing addons should work. You can can always restore the old .kodi directory and it should work as before.


#10

Thanks that look like it did the trick, an idea what caused it?