Can I use Netflix on OSMC?(post 4)


Well i got a 16gb card with only OSMC installed, standard FAT partition (/dev/mmcblk0p1 244988 34818 210171 15% /boot), the rest is ext4fs.

And i installed as late as today without issues.


You installed OSMC or the Widevine update? I installed OSMC OK, but it would not update Widevine as it said insufficient disk space. I tried it several times on different cards, nothing worked until I repartitioned it which allowed it to download the 1.9GB recovery image.


Clean install of OSMC, and then the steps to install netflix, and run netflix to get the liwidvine installation going. All worked good,


Great. Will be interested to hear if it keeps updating Wildvine OK next time. My initial install worked OK, it was just subsequent updates that gave me the insufficient disk space error.


Hi there, I followed the instructions step by step, can login, but when I want to choose the profile to watch from it crashes. Any ideas?


Just updated to the newest addon and newest nightly and i can confirm netflix addon, viaplay addon, youtube addon isn’t working. i think it has to do with inputstream.adaptive changes


alright, damn :confused: is there a way to rollback inputstream.adaptive?


instructions on first post in Leia testing thread, there is instructions on how to downgrade the version of Leia, and i think the inputstream.adaptive with it.


tried to find your instructions:
it’s either Can I use Netflix on OSMC?(post 4)
or Can I use Netflix on OSMC?(post 4)

Can you confirm?


The first link, post 130 in this thread should do it, but the version number you got to change to latest working, and according to leia test thread it was two versions ago


Alright thanks, gonna downgrade to 344 then (currently running 17.8-346)

Edit: seems to work, currently downloading chrome os

Edit2: watching videos works!



I was just wondering if anyone is able to watch Netflix whilst connected to a VPN? I am able to watch when I have stopped my VPN. I have also made sure that I am able to watch Netflix when connected to my VPN on my PC, which I am. However when I connect to the same server on my Pi, I am unable to.



I think Netflix is tightening up re. VPN use.


Hi Sam,

Yes I have heard that too. What confuses me though is that I am able to watch Netflix on my PC but on my Pi, even when I am connected to the same server.


Who is the developer of the Netflix plugin? Iv logged in but it always crashes on the user screen and my Vero resets itself.


Which version of Leia are you running, the last 2 version are booked. Try downgrade to version 17.8-345


ok will try tonight and report back


I have downgraded to 345 and 344 - Youtube now works and does not crash OSMC, but Netflix still fails to start
18:21:41.799 T:1663038192 ERROR: CAddon[]: failed to load addon settings from special://profile/addon_data/


I had issues with Netflix after downgrade, but I uninstalled the add-on and dependencies again and got it working.

I’ve made a little script of the instructions on post 4, after installing v.18 do this in ssh session.

chmod +x


I have run your script without Netflix reinstall - no success, same error message in the logs.