Can not access media on network - NFS or SMB

#1

Hi - just received my Vero today but having problems accessing my media on my Synology DS1813+

Have tried running Kodi on my Boxee Box with no network problems.

When accessing via NFS i get to my directory NFS://192.168.1.217/VOLUME1/MULTIMEDIA but can not browse it.

Have configured my Synology for NFS with the following:
IP: 192.168.1.191 (the Vero)
Privilege: read/write
Squash: no mapping
Security: sys
Enable asynchronous: yes
Allow connections from non-privileged ports: yes
Allow users to acces mounted subfolders: no

All is running on wired network and above settings worked for the Boxee Box running Kodi. Have tried changing above settings to no avail

When trying via SMB it returns and ERROR:
operation not permitted

This was also the result with the Boxee Box running Kodi.

For the life of me I can not figure out what I’m missing…

Please HELP!!!

Best regards

Henrik

Mounting NFS on new Synology OS 5.2
Synology NAS w/ PI2
Synology DS115J
#2

Hello. I have a Synology NAS as well and I needed to set the squash to “Map all users to admin”.

Here is a pic of my configuration.

#3

http://kodi.wiki/view/NFS#Synology_DSM_5.1

This also advises to Allow users to access mounted subfolders.

#4

Thanx for your input!

Worked around it by adding a SMB directory from where I could select the folders for scanning. This method gave me the interface to input username and password.

Afterwards I got NFS working as well - had not set the admin rights for the folder specifically for the admin user (not its group) to read/write

So everything working now!