Can only access Web Interface when OSX is connected wirelessly. LAN no sucess

I’m very new to OSMC/RP so forgive the stupid questions.

Current set up:

RP2 wired connected to secondary DD WRT repeater router.
OSX wired connected to secondary DD WRT repeater router.

I’m trying to access Kodi Web Interface from OSX/Wired connection, but it wont connect.

When I’m connected wirelessly, It works perfectly.

I believe this has something to do with the router settings.

Any Ideas?


What is the exact address are you trying to connect to, a hostname or an IP address ?

Thanks for your response

The ip on the RP2 is and the port is 8080

On both the primary and secondary routers I’ve port forwarded port 8080. I don’t think this mattered if I enabled it or not.

Ive tried:

Thanks again

You shouldn’t need to do any port forwarding on a local network if your wifi router is in bridging mode.

It sounds like you have a router behind a router both running NAT firewalls, so you’re going to have to explain your network setup to make any sense of that.

Yea I figured I was wasting my time with that attempt, but I had to try lol.

On the primary router, R7000, I have no firewall enabled. I turned off “Filter Multicast”

On the Secondary router DIR 600, I dont have a firewall enabled as well and the “Filter Multicast” is also off.

To connect the secondary router to the primary, I set the secondary into “Client Bridge” mode and then added a Virtual Physical Interface.

Primary router is
Secondary Router is

Also I dont know if this matters but the WAN on the secondary router is disabled. I’m not sure why it is.
Shot of WAN set up:

Here are screen shots of my setup

To avoid wasting more time (especially other peoples time) you really should explain in detail what you are trying. I assume you are trying to connect from within your LAN to the Raspberry on the IP address And this is working when the Raspberry is connected wireless but not when it is connected wired, correct?
Unless you have given the Raspberry a static IP address that it uses when connected wireless and wired it will change the IP when connected wired (to what is assigned by DHCP) therefore you will not be able to connect on
Easy solution check the new IP that is assigned after you plugin the cable.
More elegant solution configure the DHCP server to assign the Raspberry the same address for wireless and wired. This needs the DHCP server (your router) capable of assigning same IP to too different MAC addresses.

Sorry to waste your time

The Raspberry is connected wired to the secondary router at all times.

It is OSX/Macbook that can only connect to the Raspberry when OSX/macbook is connected wireless to the secondary router.

The issue I am having is connecting to Web interface when OSX/Macbook is wired to the secondary router

Maybe I need to give OSX the static IP

No the source IP should not be a problem.
So do I understand it correct that the not working scenario is Raspberry wirless on the secondary Router and Macbook wired connected to the secondary router?
If so then write down the IP addresses the Mac has in that moment and the Raspberry Pi has in that moment and we can go from there.

Yea I really have no clue at this point.

It’s weird that when Macbook is wireless connected to either primary or secondary router it can access the WIRED Raspberry PI.

But when Macbook is wired to secondary router, I can’t get through. It should be able to get through since they are both wired to the same router.

Raspberry PI and Macbook wired to secondary repeater router.

Doesn’t work when Macbook is wired to secondary router, but works when macbook is connected wirelessly to both primary or secondary routers. At all times, the RP2 is WIRED to the secondary router. I dont have a Wifi USB Dongle.

These are the IPs at the moment when Macbook and RP2 is WIRED to secondary router:
Macbook IP -

RP2 IP -

Should I give the RP2 a static IP?

Thanks for all your help. Much appreciated.

Well Static IP’s only help to make sure you know what you connect to it will not solve your connectivity problem. As long as you ensure that DHCP is working over the wireless bridge.
Ok while generally it would also help to write down the Netmask to ensure no mistake there (I assume both have or /24) I would always start with basic network troubleshooting. Try to ping the raspberry pi from the Mac.
Depending on that result try to ping the routers…HOLD ON, just seeing that your router are in 192.168.0.x while your Raspberry and Mac are in 192.168.100.x
I think you really need to first give a us a full understanding of your setup including IP Adresses, Netmask, DNS,…

Yea I feel pretty shitty wasting your time while I’m here not really understanding the depth of my issue.

Can I get back to you while I educate myself some more about whats going on?

That’s how my set up looks like on the secondary router.

I just found out that DHCP server is disabled on the secondary router. I THINK that may be the problem.

The thing is, I dont think you can enable DHCP on the repeater bridge. I may be wrong. Im going to research this some more.

Sorry for wasting your time man.

But I really appreciate the help so far. I will get back to you as soon as I can.

I have to admit that I am not 100% sure about your devices and your final goal. But I just saw that you have setup a “Client Bridge (routed)” which would indicated that the two router have own networks and no DHCP would be shared between them. What you want is a bridge that means 1 subnet where each router is a switch and not a router.

lol I dont think im 100 either on what the hell im doing right now. But my goal is to get Web interface to work while Macbook is Wired to secondary router.

That was the exact guide I used to set up my secondary router. Exact to the dot. .

Maybe that’ll give you a better idea of my set up and What I did.

Not 100% sure which dot you are refering to but that manual says “Wireless Mode : Repeater Bridge” while your screenshot show “Wireless Mode: Client Bridge (routed)”

so when the macbook and pi were wired (and both 192.168.1.x) could you ping the pi or ssh in? is it just an issue with the web interface or connectivity in general?