Can see files in "file manager" but not in "videos"

So today for the first time some of my video-files did not show up browsing through “videos”. I have a coupple shared folders here with random files that are not to be scraped that I just browse through and play by clicking the file.

The files are just invicible, they are seen on the PC but not on the TV. I made a new subfolder and put the file there on the PC but cannot see it on the TV. I tried to make a new mkv from it, but that doesnt show up either.

All old files are shown normally, and I tried to put a new file there just to see if its only these files or if I reched some kind of threshold but the new file does show up, so there is just something wierd with only these special files and I wanna know what.

The only way I can see the files are through system->File Manager
They also play perfectly fine from here.
The files are Matroska, Video:AVC, Audio:DTS

What can be the issue here? Attributes looks normal.
Have rebooted the Vero and the PC with no luck.

Provide logs so someone has a better than slim chance to guess correctly

1 Like

What will I do when creating the logs? Browse into the folder?

Yes, go into the folder via videos, then go there via file manager and then upload full logs.

I don’t know how to read regex but I suspect your issue may lie here…

====================== advancedsettings.xml =================== C7hKmH1p
<?xml version="1.0" encoding="utf-8"?>
			<regexp>[-._ \\/](extrafanart|trailer|extrathumbs)[-._ \\/]</regexp>
---------------------- advancedsettings.xml END --------------- C7hKmH1p
1 Like

Where does that setting come from? And why does it exclude these specific .mkv`s

That is from a ~.kodi/userdata/advancedsettings.xml that you would have put there as it not present by default. It has more entries than that but I chopped them out to just show the relevant bit. At a glance I would say at some point you probably followed a tutorial on adding extra fanart as that looks like the type of setting one would use to hide the extra bits that would clutter up your library. What exactly are the file names that you want to show but are hidden? Do they happen to have the word “trailer” in them as that setting would cause those to be hidden.

Hm that looks like it comes from the add-on “Extras” that makes you able to have commentary etc in an “Extra”-folder together with the movie and accesible by “right clicking” on the remote and it is an option there.

Its a little bit wierd its still there since I dont have the add-on installed. I might have reused all of the userdata at reinstall and thats why its there. Maybe if I install it again, and then uninstall it. I will try.

Yes they do have the words “trailer” in them. Atleast this makes alot of sense.

Well reinstalling and then uninstalling the addon didnt help.

I just removed the word “trailer” from the advancedsettings and its fine now, the files show after a reboot.

Thanks for the help, I really thought it had something to do with permissions or wierd video-type or something similar and that it was a known problem.

1 Like

You can ssh into your box if you want and just delete the file…

rm ~/.kodi/userdata/advancedsettings.xml

or if you just wanted to remove that one phrase you can edit it with…

nano ~/.kodi/userdata/advancedsettings.xml

Yeah I just edited it with nano. Thanks.

1 Like