Can´t download update


I am at OSMC Release Candidate Three 0.9.9 on an RPi 2. I can not update to a newer version, both auto update and manual update gets stuck at “Downloading Update: Starting Download” and it stays there forever or until you exit Kodi or start a new update.
My network are fine and i can access YouTube with the YouTube addon.

Any idés what can be done?

I have uploaded the logs here

Thanks in advance.


It would have been helpful to see the system journal and free disk space as well, but I’d suggest you try the following via an SSH connection:

sudo apt-get update && sudo apt-get -f dist-upgrade

And copy/paste any errors that you might see in this thread. After a successful update you’d want to type reboot to reboot.

If you have ticked the option to Backup before updates, then turn that off. Then try updating again.

If that doesnt work then switch on debugging and then redo the problem and the logs.

Otherwise, if you have a keyboard attached to the Pi, reboot and hold down CTRL-SHIFT to force an external update (outside of Kodi).

Hi DBMandrake and Karnage,

Thanks for your reply, I tried DBMandrake’s suggestion and that worked.

Sorry, didn´t know I should have included the system journal and free disk space when I uploaded the logs.

I hade free diskspace /dev/root was only 10% used of 15G and /dev/mmcblk0P1 was only 13% used of 240M

The option to Backup before updates was already turned off.
Debugging was enabled for the Kodi log I uploaded.


There was nothing in the log which indicated why the update Simply stopped. This might happen again if it was an intermittent connection issue.

mmmmmmm… great suggestion… usually i use the “dist-upgrade” whitout -f flag, it’s the same ?

-f means fix dependencies - this will also try to fix broken dependencies during the upgrade process. (by re-installing any missing packages that are required as dependencies that might have been removed)

Normally you don’t need this option, but we add it by default to help automate repairs if a previous upgrade failed.

Great info… thanks… in future i try to use it :smile: