Cannot Access NFS Shares

I just did a fresh install of windows today and am having issues with accessing my hanewin NFS shares on my vero 4k. I used the exact same setting for NFS as I have always used with no issue and have opened the appropriate ports on my firewall. According to hanewin the shares are mounted but osmc is giving me the “path not found or invalid” message when ever I try to access the mounts.



Your have only uploaded a few logs, so a couple of questions:

  • Are your shares mounted via Kodi or fstab? I’m guessing Kodi
  • Are you using an IP or the hostname of the Windows machine?

Can you post sources.xml? This can be uploaded via our logger.



My shares are mounted in fstab unless they need to be remounted with a fresh install of windows. I am using the ip as seen in the export list here for hanewin:

G:\Media\TV -public -readonly -name:TV2
G:\Media\Movies -public -readonly -name:Movies2
H:\Media\TV -public -readonly -name:TV
H:\Media\Movies -public -readonly -name:Movies

and in Fstab: /mnt/Movies nfs noauto,x-systemd.automount 0 0 /mnt/Movies2 nfs noauto,x-systemd.automount 0 0 /mnt/TV nfs noauto,x-systemd.automount 0 0 /mnt/TV2 nfs noauto,x-systemd.automount 0 0

I am able to see the file paths in osmc and on my phone on VLC. However, I cannot access them as it just freezes or wont go any farther when the destination folders are clicked/tapped.

New logs:

In MyOSMC do you have “Wait For Network” selected?

What happens if you try to manually mount:

sudo mount /mnt/Movies

I toggled that setting on and off and it made no difference. Using that command I got Capture

That error shows that the network actually disconnected when you tried the mount. I think you need to verify that the network on your PC is OK.

Is there anything specifically on my network I should verify?

The networking on you Windows system, since this was apparently working until you reloaded Windows. And check your router. Maybe some IP addresses changed?

I set the same IP address as before in the adapter settings. The IP for the vero has remained unchanged as well.

Do you have another system that you can SSH into the Vero from? Have you checked the Windows Event Log for errors?

Try an SSH app on your smartphone or access the command line with a keyboard.
It sounds like some network connectivity issue however


Said connection timed out when I used a phone app.

I was trying different file paths to try in NFS and they were working just fine. It seems paths that go through my two drive pools are the cause of the problem. I am not sure if there are permission issues that are preventing the files from being read over the network. Its strange because plex has no issue with them and before I reinstalled windows there was no issue as well.

Do you mean the SSH connection to the phone timed out, or that the mount command timed out?

If it’s the mount command that timed out, then you really need to look at your Windows setup. Since SSH from Windows disconnects, that points to a major network or software issue. Make the NFS server on the Windows system is crashing. Did you look in the Event Logs?

I am more than certain it is the drivepool software that is causing the problem.

Latest version of hanewin had this change:

1.2.30 NetworkLockManager added
file-id as inode for NTFS on win7 and higher
gui modified

And that was why the drivepool wasn’t accessible via NFS, downgrading to hanewin 1.2.29 fixed the issue. Considered it solved, thanks everyone for the help.