Cannot access osmc using kore or web-browser

I’m hoping I can get some help here, pulling my hair out with frustration.
Have a Raspi2 with wireless dongle, was trying to improve the connection quality for some streaming services so connected up a lan connection to the raspi, alongside the wireless dongle (using hdmi output to tv). Then the Kore app I am running on my android phone as a remote control stopped working fully: initially it would only allow the arrow keys to work, but not the selection key. Then I tried to reconnect via Kore by deleting the osmc profile and adding it again, the media centre would be found but would not connect. Now the media centre is not showing at all on Kore.

I can connect via Putty on a windows laptop to the osmc. I have no separate keyboard so cannot plug it in to the raspi to go and check any settings etc.

If I put the ip address of the osmc into a web browser ( it prompts for a user name and password ( is requesting your username and password. The site says: “XBMC”) but despite using the defaults of “osmc” which I have never changed, it doesn’t work.

So any advice on how to headlessly check the settings or fix this problem would be much appreciated!

I have managed to now access using a web browser. This is after I noticed, looking at the settings file via Putty, that I had changed the webserver user name and password. So I can do any other steps that are suggested

I uninstalled Kore and reinstalled but no difference. I then restarted my phone and it worked, but I think a new VPN service that had been installed on the phone was interfering with the remote control so I disabled the VPN and then Kore would connect! Is there a way of running the VPN service on the phone and also using Kore?

That depends on your VPN service. If the service routes all traffic (including local) via the tunnel or on purpose blocks LAN traffic than no chance to have VPN and Kore working together.