Cannot add sources in file manager

Hi, I’ve been using osmc for quite some time now. I used to have the ability to add sources from the file manager. Now it seems I do not.

I am connecting from Raspberry pi with osmc to another raspberry pi running raspbian. I previously added a share to osmc via ssh. Now I cannot even see ssh as an option any more. So I tried setting up ftp and even samba (which I very much dislike) and created shares for both in osmc. Nothing works. I am able to connect to and use those ftp / ssh / samba shares from my phone, Mac, Linux boxes, android devices ect., but osmc cannot see them. I even tried reinstalling osmc from scratch a couple times. My network is working properly, I can update and install addons in osmc. About 1 years ago things went on the fritz with osmc connecting to servers. Any ideas as to why this might be happening for me?

settings>media>general>show “add source” buttons>[enable]

Logs may give some insight to the reason…

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

I’m sorry the “add sources” button is checked. I can go through the process of adding sources. It simply fails every time I do so. I was more commenting on the fact that I no longer can add an ssh share when selecting from the types (samba, WebDAV, ftp, ftps ect). Several years ago I was able either ssh or sftp, it’s been a while.

Anyway I am looking at the logs and I’m seeing the part where there error is happening. What do you need included ?

ftp://USERNAME:PASSWORD@server.local:21/home/user/
2020-06-20 19:38:43.223 T:1538249440 ERROR: CCurlFile::FillBuffer - Failed: Access denied to remote resource(9)
2020-06-20 19:38:43.223 T:1538249440 ERROR: CCurlFile::Open failed with code 550 for ftp://USERNAME:PASSWORD@server.local:21/home/user/:
2020-06-20 19:38:43.223 T:1538249440 ERROR: GetDirectory - Error getting ftp://USERNAME:PASSWORD@server.local:21/home/user/
2020-06-20 19:38:43.223 T:1538249440 DEBUG: Thread waiting 1538249440 terminating

I was going to look for any errors in your sources.xml and make sure it was actually loading but it obviously is from that snippet. If you know that source path is correct I would check your .kodi/userdata/passwords.xml and make sure the credentials being sent are correct.

This is the contents of my passwords.xml

<passwords>
    <path>
        <from pathversion="1">sftp://server.local/</from>
        <to pathversion="1">sftp://user:pass@server.local/home/user/</to>
    </path>
    <path>
        <from pathversion="1">sftp://server.local:22:/</from>
        <to pathversion="1">sftp://user:pass@server.local:22:/home/user/</to>
    </path>
    <path>
        <from pathversion="1">sftp://server.local:PortExternal:/</from>
        <to pathversion="1">sftp://user:pass@server.local:PortExternal:/home/user/</to>
    </path>
</passwords>

It looks like my passwords are correct. If I remember my xml correctly I think the special characters are converted
asterix = %2a
If that is correct then everything else is good

So I’m having issues displaying the xml in readable rich text format. It’s been a while since I’ve tried to do this.

(mod edit: You select the text and click on </> to post code)

I know relatively little about ftp sources in Kodi but I believe that if your doing sftp you have to install an add-on for it. You would go to add-ons>my add-ons>virtual filesystems>SFTP Support> bring up info and enable it.

Ok I enabled sftp and now it gives me the option to add an sftp source, but when I go to commit, I get a frowny face. Nothing in the kodi.log

SFTP issues are problematic at the moment.

That’s fine, I setup ftp on that server also. I would just like to successfully connect somehow

You could use autofs to achieve this for now. I’m hoping SFTP is fixed in the move to Buster

Sam

If the server is raspbian why not use NFS?

I don’t believe I have nfs setup and honestly I have not done that in quite some time. I’ll have to get back on that

NFS server isn’t that hard to setup. Basically you just install nfs-kernel-server and edit your /etc/exports to get the server running.We have tutorials here on how to setup fstab or autofs on the client if you decide that you wish to switch to system mounts instead of Kodi mounts.

I just skimmed through a tutorial. I have not setup nfs before. I’ll try it out tomorrow. I need sleep

Let us know if you need help with the server setup. I’ve set it up lots of times.

Remember that the tutorial here are just for the client, not the server.