Cannot complete installation of OSMC in Vero V

My Vero V seemed to work ok for a few days, but then it began displaying a uniform clothlike/houndstooth pattern on the display. After power cycling multiple times, it will eventually produce the osmc screen. I thought this might be caused by a corrupted OS so I attempted to reinstall osmc using an sd card with an image generated using the installer on the downloads page. The installation begins but hangs at “Installing files” at about 50% or gives the message “Install failed: Segmentation fault”. Other things I have tried:

Multiple Displays / Multiple HDMI cables (pattern still appears more often than not)
Multiple power supplies (Vero V power supply / Vero 4k power supply)
Multiple SD writers (different laptops)

I have already spent many hours trying to get this to work, any advice would be appreciated.

Can you try with a USB and fresh download?

There might be an issue with the device itself.

I have tried unsuccessfully with a USB to SD card adapter: in each USB port, with multiple SD cards and multiple image downloads. I do not have a USB stick around, but the adapter functions normally with my Windows PC.

Thanks for the fast response.

Can you try with a USB stick from a friend?
Otherwise I am happy to swap this over for you regardless of whether there is a hardware issue or not.

I can see you’re in the US – did you purchase from us or through a reseller?


I will have to buy a USB stick. I purchased the Vero on Vero - OSMC. My 4k+ is still working great in the meantime.


I’d be surprised if multiple SD cards have failed.
Before you spend money on anything, let me have a think.

We should be able to image the device and perform an integrity check.

Do you have a USB-A to USB-A cable?

There is also another approach we can use for reimaging the device. You’ll need a toothpick or non conductive pin that fits in to the round CVBS slot on the back of the device.

I have a USB A to A and a toothpick. Is the CVBS slot the AV jack?

Hi – it is indeed. If you take a non-conductive pin and put it in you should hear a soft click. Once you confirm this, I can send you some further instructions



OK, I have done this with the unit powered.

Did @sam_nazarko not send you a pm with additional information? If you click on the hamburger menu at the top right of this site is there something showing in your inbox?

I will send it through shortly, just verifying it here.

The inbox is empty.

Thanks for your patience.

Please write the following image to a SD/USB drive using the OSMC Installer selecting ‘local image’.

And please take a screenshot of the contents of the media after doing so to ensure it’s correct.

With the Vero powered off, insert the USB or SD card.
Now apply power with the toothpick pressed in for about 10 seconds and release it.

After a period of time, Vero V’s blue LED should start blinking periodically.
This means that the device has been re-imaged.

You can now remove the installation media, remove power, wait five seconds and re-apply power.
The device should now boot.


I followed the instructions in the last post. Despite numerous attempts, the blue light did not blink. I can hear and feel when I release the reset button >10s after powering up. 9 times out of 10, no text appears on the screen, just an image of a logo (S905X4 ) followed by the pattern shown in the attached image Screenshot.jpg. Occasionally several pages of text scroll quickly on the display and finish with the image in Screenshot2.jpg

Please advise


Hi Howard

It could be user error but I doubt this.
I suggest contacting with your order #, a link to this thread and I will get this solved promptly.

Let’s swap your unit over

Have a good New Year


Thanks, I will do that


Great – will pick this up shortly.