Cannot connect to files on FTP server

Hi guys, I use recently went back to OSMC on my pi 3 from libreelec and am having problem connecting to my server via FTP. I use mysql to sync my video library and worked fine for a few days, now, possibly after an update, I am unable to connect to the videos on my server via FTP through the video library. I use the same sources.xml, medialibrary.xml and advancedsettings.xml for my PC and have no trouble there.
Performing a fresh install of osmc fixes this temporarily, then stops working after a while.

Within the debug log there is this:
21:04:56.911 T:1958420480 ERROR: CCurlFile::FillBuffer - Failed: Login denied(67)
21:04:56.911 T:1958420480 ERROR: CCurlFile::Open failed with code 530 for ftp://USERNAME:PASSWORD@
21:04:56.911 T:1958420480 ERROR: GetDirectory - Error getting ftp://USERNAME:PASSWORD@

Any advice?


From the error codes, appears to be authentication failure.

I would check sources.xml on the pi3 and make sure the username and password are correct.

Other than that, full debugging logs may shed more light.

Thanks Tom.

Hi Tom,
I have checked that the password is correct.
I have also copied the files to the userdata folder on the kodi on my pc and verified that I can get the videos to work.


The logs, will tell us more then.

Thanks Tom.

Hi Tom,
Thanks, I have uploaded the logs here.
Full log -
Kodi debug log -

Hope this helps.


Probably not the issue, but I would remove from this advancesettings.xml:


Its redundant, has been superseded by <cache>, which you also have in there.

I will see what else I can find.

Thanks Tom.

Hi Tom,
From what I can see the server doesnt seem to be playing nice over FTP.
I will try and have a look at that too


I’ve found this google:

(I know its do with rar files, but the ftp error is the same and I don’t think the rar files is the cause of the issue the person is having.)

Does your ftp server have tls enabled, if so whats happens if you switch that off?

Thanks Tom.

Hi Tom,
thanks for your help. It seems that the my synology server had an autoblock feature and happened to have blocked my pi IP, no idea why that would have happened. That explains why it worked on other computers and why it worked once I reinstalled OS, after testing I set the IP address manually.
Cheers for your help!


Glad to here its sorted.

Regards Tom.