Cannot connect to WiFi - Networking add-on unhandled exception caught

What happened

  • I have installed the system completely new with the provided installer onto an SD card
  • I have provided the wifi credentials in the installer wizard, the wifi network is not connected, though
  • in “My OSMC > Network” I can select the wireless tab and also can see my network SSID in the list. When I connect, I am prompted for my password and then I get the error “Networking add-on unhandled exception caught” and that I should check the logs

How to view the logs?

  • I have tried to do the troubleshooting with similar issues in the community here, but my problem is that I can’t see where I can view the logs. I have no network connection, as my wifi does not work - so no uploading of the logs is possible. I can work on the RP with a screen and a keyboard
  • When downloading the logs onto the SD card, I can’t see any logs anywhere on the SD card. I have checked both partitions on the SD card. I use a Mac.
  • I have tried the grab-logs in the command line tool with the -P option to view them directly on the screen, but if I print all, it is too much. Maybe a hint on the specific log I would need could help. Or how I can scroll upwards in the command line tool with just a keyboard.


  • Rasberry Pi 3
  • the same hardware-setup used to work before, so I do not expect any problems with my wifi-network and the router

Thanks in advance.

If you use the -C option (along with -A) you’ll find the full log file at /boot/uploadlog.txt

Thanks a lot, this actually helped me:

  • executing the command you mentioned gives feedback that the file is stored in the FAT partition. This, together with the filename gave me the solution I needed.
  • The actual logfile had a wrong timestamp, perhaps the whole device had without connection to the internet. This also made it harder to find the file.
  • Within the logfile I made a text-search for “error” and identified the relevant passages.
  • error seemed to be that the password had a typo. But this must have been the password, which had been stored from the installation wizard, as I did type in the password repeatedly and also with the on-screen keyboard in the OSMC UI. To me this looks like once it is wrongly stored, you cannot override it from within the UI. Perhaps a config change might have helped, but I did a complete new installation that did the job for me.


1 Like

The Raspberry Pi doesn’t have a realtime clock. So it would not know the time until it can connect to the internet.

Good to know, thanks for clarifying.