Cannot Delete VPN Service - Need Help

I no longer want to use a VPN service on my Vero 4k. Steps taken:

  1. Did a manual backup.
  2. Disabled OpenVPN application; rebooted. VPN service still launches.
  3. Uninstalled OpenVPN application; rebooted. VPN service still launches.
  4. Selected “Reset” to erase all settings, etc. Rebooted. VPN service still launches.

What do I have to do next to not use a VPN service any longer? Any help/ideas would be greatly appreciated. Thanks!

If you had installed a Kodi OpenVPN add-on, which you later deleted, it’s possible that the underlying OpenVPN executable is still installed (or vice versa). Unfortunately, from reading your post, it’s difficult to know which, if any, of these possibilities is the case.

If you post full logs – they don’t need to be debug logs – perhaps the situation will become a little clearer.

It is also possible that your SD card has failed and gone into read-only mode, that’s what it sounds like to me

1 Like

Thank you very much for your reply. Unfortunately I lack the skill to provide the log you requested even after I read the instruction link you provided.

Ever since I put that VPN service on my Vero 4k, I have had a number of problems. I think it is time for me to abandon this hardware platform since I lack the technical skills to maintain it. I used to be able to SSH into the device but that function no longer works.

Again, thank you for your reply. It is kind folks like you who make this community a real community.

Thank you for your your reply. I did not have an SD card installed in my Vero 4k. I guess I assumed that any backups would be automatically retained in the Vero’s on-board memory.

I think I will say “goodbye” to the Vero 4k device. I am experiencing too many problems after I installed the VPN service.

However, let me thank you again for your suggestion. It is kind folks like yourself who make this community a real community.

Ah I didn’t realise it was a Vero 4K, I had assumed it was a Raspberry Pi (my mistake). If you didn’t mind starting over from scratch it should be relatively painless to perform a clean install which should guarantee that all traces of the VPN are gone, for that I think you just need a spare USB stick or SD card. Instructions are here;


I think a reinstall should get you up in working order quite promptly.
It should not take more than five minutes.

We are here to help


I think it is time for me to move on from the Vero 4k+. I believe I lack the technical skills to use and maintain the device.

The present state of affairs after trying a number of trouble-shooting steps is that the device displays “Please stand by” on the screen and that’s it. So I have managed to “soft brick” the device.

I was unable to install a new image using a USB stick.

I was unable to get the reset function to work.

Prior to my efforts to remove the VPN service I installed several months ago
I was unhappy with the performance of the Vero 4k+ device. I have high-speed cable from Comcast (180mps down); I have their latest and most expensive modem, I have a Netgear Nighthawk R8000 router, I have Cat 5e structured LAN cable running to a homerun panel, and I have a Cat 5e patch cable from the LAN jack to the Vero 4k+. In spite of all this expensive equipment, I have never gotten 1080p sources to run without impossible-to-use buffering (and forget about 4k content).

I want to thank the users who attempted to help me resolve my various issues. And I want to thank Sam for his support and hard work over the years of my use of OSMC and his devices. Best regards and thanks again everyone!

I’m happy to help you with this over the phone.

Alternatively, if you know someone who is a little more resourceful with things (I mean no offence); I can also help them restore the device.

We are always trying to make OSMC and Vero more accessible for users and reduce the barriers to entry to operate the device.

I will re-read over all your correspondence on this forum and reach out to you via email in the coming days


1 Like

Hi, Sam . . .

Thank you for your reply and offer of assistance. Please wait until you have 18.x rolled out. I know the community is anxiously waiting for that release and I do not want you to slow down progress on that for me.

Update from April 1st:

I have managed to get from the “Please Standby” screen to a screen with the following messages:

Waiting for root filesystem device /dev/vero-nand/root

After about 20 seconds, then this appears on the screen:

FATAL ERROR: Could not find root filesystem device /dev/vero-nand/root – if this is a USB install please check the USB drive is connected.

** OSMC initramfs Rescue Console.**
** For help and support see**


I know that the “#” symbol signifies the “superuser”. I have a book of Debian Linus commands, which makes me dangerous. I can use some of the commands but not enough to get my Vero 4k+ back in service. I have tried using a USB stick and also an SD card to load the December imagine without any luck. Really, I am just “hunting and pecking” at commands trying to navigate to different directories to see what I could find and what commands to try to execute.

I tried to SSH into the device with PuTTY from my Windows computer but, as you probably know, I cannot do that at this point.

I have downloaded the 2018.12-1 image file for the Vero 4K/4K+ and extracted the “.img” file from the “.gz” file on my Windows PC. I just don’t know how to get the extracted file on to the device in the right place so the device boots up correctly.

Take your time to respond, Sam. I know that you have your hands full with other, more pressing, matters.



Use the OSMC installer and it will partition the SD card / USB appropriately to facilitate the reinstallation. If this does not work as expected, please show us a screenshot of the contents of the SD card / USB.

Hi, Sam . . .

Well, that did the trick. Apparently, the 32gb microSD card I was using had too many partitions on it so my previous attempts with the installer program failed when the installer file couldn’t be found on the microSD card when I inserted it into the Vero 4K+ device. So I re-formatted the card and used the installer again and it installed 2018.12-1 perfectly. And since I had already done several hard resets of the Vero 4K+, the box is clean as a whistle with no VPN service or other apps installed.

Thanks, for your help and patience with me, Sam. I appreciate it.



Glad to hear this.

1 Like

I too am glad to hear this Phil. I know technology can be frustrating at times but we are here to help and can usually simplify instructions to basic steps. I’d have been sad to know you had paid good money for a Vero 4K but were unable to use it, that wouldn’t have been good for you and an unsatisfied customer is not good for OSMC either.

A good result all round.


For what it’s worth, I’ve been using the Zomboid openvpn add-on with my Vero4k, for a year or so. It appears, anecdotally speaking, to cause some sporadic playback issues (delays, buffering, complete UI freezes), even of local sources. Often I leave the vpn disconnected to avoid such problems.

I also find it far too easy to trash my setup (I’m required to use ‘user defined’ as my vpn provider is unlisted).

Not to worry, with the EU’s passing of Article 11 and 13 (since renamed to 15), the outlawing of vpns is a logical next step (and not just in my humble opinion), which will at least resolve the issue (which is not in any way OSMCs fault), if not in a desirable manner.