Cannot enable tethering


I bought a new wireless adapter and tried to enable “wired to wireless” tethering. Got an error message. Here’s what the log says:

09:53:58 T:1614529568 NOTICE: Enabling wifi tethering
09:53:58 T:1614529568 NOTICE: Error enabling Tethering net.connman.Error.PermissionDenied: Permission denied
09:54:17 T:1614529568 NOTICE: Enabling wifi tethering
09:54:17 T:1614529568 NOTICE: Error enabling Tethering net.connman.Error.NotSupported: Not supported
09:54:46 T:1614529568 ERROR: EXCEPTION: Non-Existent Control 50

The wifi adapter is working out of the box (I connected to another wireless network before).
Enabling “wireless to wired” also works.

Thanks in advance.

Device: Rasp Pi 2
Ram: 1024
Installation media: SDcard
Connection: Wired, Wifi
Peripherals: Logitech BT Mini Receiver, TP-Link TL-WN823N wireless adapter
OSMC version: OSMC Rc3 0.9.9
Overclocked: No
Config.txt Extras:

I believe that adaptor is using the 8192cu driver (would need to see dmesg to be sure) in which case at the moment it does not support wifi tethering on OSMC. It’s something on our todo list but it is not trivial to fix so there is no ETA at the moment.

Have done some digging.

The issue is that the driver we use does not implement nl80211 properly. Instead, it uses rtl871xdrv. hostapd can be configured to use this with driver=rtl871xdrv. In fact, inserting this in to /etc/hostapt.conf, should do the trick

# include this file from your own hostapd.conf


Unfortunately, ConnMan only supports nl80211 at the moment. I’ll investigate it.


Thanks for the reply!

Unfortunately I am not experienced with Linux.
Is the hostapt.conf supposed to be in /etc/ in the first place? Do I have to create the file?

I might just wait for the fixing update.

There is no fix for this scheduled at this time


Hi Shrake. I had the same problem with my USB wifi adapter that uses a Realtek chipset. I bought one using the Ralink RT5370 chipset and it worked without any issues to tether wired to wireless.

It was pretty cheap on Amazon:

Not sure if I should start a new thread, but I am Facing a similar situation but different adapter RTL8188CUS :

osmc@osmc:~/.kodi/temp$ uname -a
Linux osmc 4.1.3-2-osmc #1 SMP PREEMPT Tue Aug 4 11:44:21 UTC 2015 armv7l GNU/Linux


[    3.480131] usb 1-1.2: New USB device found, idVendor=0bda, idProduct=8176
[    3.480163] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    3.480181] usb 1-1.2: Product: 802.11n WLAN Adapter
[    3.480209] usb 1-1.2: Manufacturer: Realtek
[    3.480226] usb 1-1.2: SerialNumber: 00e04c000001

lsusb(had to install usbutils):

Bus 001 Device 007: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

and ~/.kodi/temp/kodi.log:

osmc@osmc:~/.kodi/temp$ tail kodi.log
01:47:35  14.255743 T:1586254880  NOTICE: UDP: Listening on port 9777
01:47:35  14.259555 T:1577866272  NOTICE: Thread TCPServer start, auto delete: false
01:47:35  14.471627 T:1534719008  NOTICE: Thread AirPlayServer start, auto delete: false
01:47:37  16.399578 T:1689572384  NOTICE: -->Python Interpreter Initialized<--
01:47:49  28.414728 T:1670698016  NOTICE: Previous line repeats 1 times.
01:47:49  28.415012 T:1670698016  NOTICE: Thread LanguageInvoker start, auto delete: false
01:47:49  28.473917 T:1670698016  NOTICE: -->Python Interpreter Initialized<--
01:47:51  30.290716 T:1689572384   ERROR: EXCEPTION: Non-Existent Control 300
01:48:03  42.424831 T:1498014752  NOTICE: Enabling wifi tethering
01:48:03  42.427933 T:1498014752  NOTICE: Error enabling Tethering net.connman.Error.PermissionDenied: Permission denied

Any suggestions are appreciated.
EDIT tried adding a hostapd.conf ( I assumed hostapt.conf name was a typo), but does not seems to help:

osmc@osmc:~/.kodi/temp$ more /etc/host*



Any luck getting this to work with osmc?
I can connect to the AP but kodi doesn’t see my phone at all.

Like it’s not on the same network.
I want this for a car pc project I’m building.
thank you!

Hey, did you find any solutions for this?
I am building similar project !

Hi guys. I’ve got RTL8188CUS usb adapter and it is useless for tethering.
Encouraged by Bobafred I acctually bought Ralink RT5370 adapter.
Never the less this one doesn’t tether too. Still I’ve got same error message:

Error enabling wifi tethering: Permission denied
Error enabling wifi tethering: Not supported

Any clues? Driver isn’t the problem here I think.

Not all devices support it, due to a lack of nl80211 implementation

We will try and compile a list in the near future. We are now producing a 5Ghz dongle in the near future which will support tethering

Was there any fix for this?

Unfortunately, not at this time.