Cannot FTP to OSMC

I am having trouble getting FTP working through FileZilla (RPi2 running RC3). I have read a number of related posts, but none seem work for me. I get the impression that many of the threads were started before OSMC had a functiong FTP app. For example:

I have no trouble remotely accessing OSMC using SSH.

Here is what I have done:

  • enable the FTP app through the AppStore

  • reboot OSMC

  • verify that the FTP service is “running” in myOSMC >> services

  • verify I have the correct IP address: myOSMC >> Network

  • attempt to login to FTP through FileZilla (standard FTP on port 21), USER:OSMC and PWD:OSMC. (I also tried with my OSMC password, which I changed from the default, but same error.)

    Status: Connecting to…
    Status: Connection established, waiting for welcome message…
    Status: Insecure server, it does not support FTP over TLS.
    Command: USER OSMC
    Response: 331 Please specify the password.
    Command: PASS ****
    Response: 530 Login incorrect.
    Error: Critical error: Could not connect to server

  • attempt to login using SFTP on port22 and same user / pwd combinations from above:

    Status: Connecting to…
    Response: fzSftp started, protocol_version=2
    Command: open “OSMC@” 22
    Command: Pass: ****
    Error: Authentication failed.
    Error: Critical error: Could not connect to server

Thanks for your help.

The username and password are lower case

1 Like

@sam_nazarko - thanks. I am pretty sure I tried that too, but I will double-check later today and get back.

@sam_nazarko - just got it to work. I used regular ftp (not sftp) and the osmc password I had changed from default “osmc” (i.e. the same one I use for SSH). I was under the mistaken impression that the ftp password would be different than the general one. Thanks for your help.

Status: Connecting to…
Status: Connected to
Status: Retrieving directory listing…
Status: Directory listing of “/home/osmc” successful

Just my opinion but… I really don’t see much use for FTP any more… sftp seems to have quite a few more pro’s.

From What’s the Difference Between FTP and SFTP? - Titan FTP Server

Unlike FTP, the SFTP protocol is packet-based instead of text-based. Where FTP might send a command such as “DELE file.txt,” SFTP would send a binary 0xBC and then “file.txt.” The key difference is that by sending less data, the SFTP protocol is faster over the long-term as less data is crossing the wire.
Another difference is that with SFTP, file transfers are performed in-line over the main Control Connection, thus eliminating the need to open a separate Data Connection for transfers. This has many benefits. First, by re-using the main connection, no other connections are opened between the client and the server, resulting in a single secure, efficient connection through firewalls.
Since SFTP runs over SSH, it is inherently secure. There is no non-secure version—the encryption cannot be triggered or turned off using AUTH commands, as in FTP/S. This is a plus for system administrators who are trying to enforce corporate security policies.

@ActionA - thanks, I did not realize I could connect the same way with SFTP. I tried SFTP too (in FileZilla, using the same user / pwd as regular FTP), and it works just as well.

I use SCP (WinSCP) to copy files back and forth, no need for any FTP server running. If you can SSH then you can SCP.

Interesting. Now that I have FTP working through FileZilla, is there any benefit to go to the WinSCP option? I guess this would allow me to turn off the FTP App / Service - does that give any significant performance gain on a Pi2?

FTP is faster than SFTP


FTP is significantly faster than SFTP because there is no overhead for the encryption