Cannot get 3D MVC MKVs to play in 3D

Hello everyone,

I am a complete newb when it comes to Kodi and wasnt able to find any answers via forum search so I figured I’d try my luck here. I apologize if this has been discussed elsewhere.

I just received my Vero 4k+ and can’t seem to get 3D MVC MKV backups to present in anything other than 2D/monoscopic. I have over 40 3D movies that I’ve backed up and all play in 2D. Here are my settings/things I’ve attempted thus far.

Player Settings
Adjust display refresh rate: on start/stop
Sync playback to display off

Stereoscopic 3D settings
Playback mode - ask me
Preferred mode - same as movie

I’ve tried messing with different naming conventions - both and movie.3d.mvc.mkv - no luck. Kodi detects all movies as 3D.

Vero is outputting to my 3D projector which detects 3D when I switch to SBS or O/U modes.

Build is up to date. Any help would be appreciated!

Thank you!

Have you installed the 3D build?

If it’s not included in the build osmc updates to when first setting up then I’m going to have to say no. If not, I’ll continue looking around and try that first. Any quick links to the 3d build and install guide would be appreciated.

Thank you again for the quick response.

Here you are: 3D Frame Packed output

It’s a separate build as it’s not ready for prime time just yet.

Thanks for the link. I’ve installed the 3D build and now have the option of utilizing hardware based 3D mode, however, I’ve ran into a couple issues.

This pattern is displayed with every movie

Also, I dont think my projector is even detecting it as a 3d signal, whereas it was able to detect SBS/TAB prior to adding the 3D build.

Btw, should I be posting this in the 3D build thread?

Just did a fresh install using OSMC build from November along with the 3D build. Same issues.

Any other thoughts would be appreciated. Could I have gotten a bad Vero unit? Everything else works great 4k, atmos etc

Your device won’t be bad if everything else works. As mentioned, 3D is experimental.

Please upload some debug logs.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Apparently it doesn’t like to output a 3D 1080p signal with the display resolution in system set at 4k60. Switching to 1080p60 seems to have fixed the issue. Thanks again for your help.


You shouldn’t set your resolution to 4K. Leave it at 1080p and enable Adjust Refresh Rate.


We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.