Cannot get OSMC to install on RPI4

I have selected OSMC from the Raspberry Pi Imager and successfully burned the image to my SD card. Upon placing this into my RPi4 and booting, I receive the initial OSMC screens which indicate it is being installed. After completion, the RPi roots, and gives me the Raspberry Pi Imager screen. It is like the install process corrupted the OSMC s/w on the SD card and the RPi now thinks there is no operating system installed. What is causing this and how do I get out of this loop? Thanks in advance.

That tool might be installing an outdated build that isn’t compatible. If you use the OSMC installer program you find by clicking on the “download” link at the top of the site that should work for getting you a working RPi 4 install.

I tried both methods and received the same OSMC version and the same failure results. Tried different SD cards too.

Do you have another PSU you can test with? Have you tried running RPi OS, or LibreELEC to see if that runs without issue? We haven’t updated the installer image too recently and if there was an issue with it I would think we would have known about it by now.

The PSU I have is the official one that came with the RPi 4b; I do not have another. The Pi has been working without issue for at least a year now running LibreELEC (on a different SD card). I did use the card I am trying to load OSMC onto and loaded both LibreELEC and RPi OS (individually of course) from the installer and directly from their respective sites. All those options worked. It is just OSMC that has an issue. Given the release date for OSMC is 2023-08-31, I would have assumed any significant bugs such as this would have already come to light. That’s why I initially assumed it was something I was doing (or not doing), but I have tried most everything I can think of. BTW - I am not over-clocking the Pi or anything like that. I am beginning to think this may not have an easy answer, especially if I am the only one seeing it. I’ll play around a bit more and will post if I discover anything. Thank you for your replies, I do greatly appreciate it. Best regards.

1 Like


Could you please post a screenshot showing the the contents of the SD card?

Regards Tom.

This morning I ran the RPi Installer from the RPi rather than my Windows PC. Would have assumed I’d receive the same OSMC release but it does act differently. After configuration, the RPi does successful boot into OSMC. However, any system changes I made, such as changing the skin, installing a video add-on I typically use, work but only until the next RPi reboot. Then, I am presented with the initial system one sees right after OSMC setup. All customizations are gone. The add-on is gone. This really has been quite frustrating and ultimately for what I was attempting to do, it really is not worth the approximately 14 hours I have invested into this. At this point, I am just going to install a fresh copy of LibreELEC and move on. For whatever reason(s), OSMC is just not working for me.

Sounds like a failing or corrupt SD card…

I thought this too, which is why I have tried three different SC cards. Sames results with OSMC on all three. All three run LibreELEC without issue.

Haven’t been any other reports here, so I suspect it’s a localised or hardware issue.

When the system doesn’t boot - do you see the Pi boot status or any lights on the device ?