Cannot get root access via WinSCP

Greetings friends:

I’ve looked and have found threads on this subject, but I cannot get it to work. I’m using WinSCP logging in Kido 16 (USB install) with osmc/osmc then I run a command box with WinSCP. The command I used is sudo passwd root and WinSCP hangs and disconnects without giving me root access. These are the instructions from located at Usernames and passwords - General - OSMC

Can somebody give me some direction? Or point out what I’m doing wrong? It seems straight forward, but maybe I’m missing something. Thanks again.

Root access by WinSCP is blocked, edit your connection in WinSCP>Advanced>WinSCP Shell and change the shell to “sudo -su” then save it, this will give root access to the complete file system. Save the new connection with a new name and use it only when needed, otherwise use the original connection.

Wow, thank you very kindly for this information. It worked !


You cannot use “Send Command” in WinSCP to run a command that requires user input.

1 Like