Cannot install raspotify

Hello. I have done a fresh install of OSMC on my RPI 4, and I wanted to put raspotify, as it was working well on my RPI 3 before.
However when I try to install, I get:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
raspotify : Depends: libasound2 (>= 1.2.4) but 1.1.8-1 is to be installed
Depends: systemd (>= 247.3)
Depends: init-system-helpers (>= 1.60) but 1.56+nmu1 is to be installed
E: Unable to correct problems, you have held broken packages.

This is a known issue for the raspotify dev,with the answer being that this is OS is unsupported.

Any suggestions please?
Thank you

Did you try the suggestion in that thread?

“raspotify was working for you before, try manually dIf ownloading 0.31.8 and installing that”

Failing that you’ll need to wait till OSMC is updated from Debian Buster to Debian Bullseye, this is one of the next major updates planned OSMC on the roadmap but i don’t have a date for you.

1 Like

Thanks. It didn’t work with 0.31.8 or 0.31.7, but after persevering it worked with 0.31.4.

For anybody looking for what is working: I downloaded v 0.31.4 from the releases page, and ran sudo apt install ./raspotify_0.31.4.librespot.v0.3.1-34-ge5fd7d6_armhf.deb


not working for buster osmc .
did try manual install as well

Abhängigkeitsprobleme verhindern Konfiguration von raspotify:
 raspotify hängt ab von libc6 (>= 2.31); aber:
  Version von libc6:armhf auf dem System ist 2.28-110.4.
 raspotify hängt ab von libasound2 (>= 1.2.4); aber:
  Version von libasound2:armhf auf dem System ist 1.1.8-1.
 raspotify hängt ab von alsa-utils (>= 1.2.4); aber:
  Version von alsa-utils auf dem System ist 1.1.8-2.
 raspotify hängt ab von libpulse0 (>= 14.2); aber:
  Version von libpulse0:armhf auf dem System ist 12.2-4+deb10u1.
 raspotify hängt ab von systemd (>= 247.3); aber:
  Version von systemd auf dem System ist 241-7~deb10u8.
 raspotify hängt ab von init-system-helpers (>= 1.60); aber:
  Version von init-system-helpers auf dem System ist 1.56+nmu1.

same dependency error.

What version of raspotify were you trying to install?