Cannot install Samba due to Segmentation fault

I recently installed OSMC 2017.08-1

Everything was working fine, except for Samba.
I have tried installing from the app market, but just nothing happens (on GUI).
Then I tried command-line

apt-get install smb-app-osmc

and I have found that during the installation process there is a Segmentation fault.
So I tried

apt-get update

it went OK, but

apt-get dist-upgrade

has again Segfault:

Preparing to unpack …/libbind9-90_1%3a9.9.5.dfsg-9+deb8u14_armhf.deb …
Unpacking libbind9-90 (1:9.9.5.dfsg-9+deb8u14) over (1:9.9.5.dfsg-9+deb8u13) …
Preparing to unpack …/liblwres90_1%3a9.9.5.dfsg-9+deb8u14_armhf.deb …
Unpacking liblwres90 (1:9.9.5.dfsg-9+deb8u14) over (1:9.9.5.dfsg-9+deb8u13) …
Processing triggers for mime-support (3.58) …
Setting up python-dnspython (1.12.0-1) …
Segmentation fault
dpkg: error processing package python-dnspython (–configure):
_ subprocess installed post-installation script returned error exit status 139_
Setting up python-crypto (2.6.1-5+deb8u1) …
Segmentation fault
dpkg: error processing package python-crypto (–configure):
_ subprocess installed post-installation script returned error exit status 139_
dpkg: dependency problems prevent configuration of python-samba:
_ python-samba depends on python-crypto; however:_
_ Package python-crypto is not configured yet._

I’m not able to upload logs, because

grab-logs -A

gives also Segfault and uploading logs from MyOSMC does nothing.
Should I just try the previous version?
Any other ideas?


  • Piotr


It seems like your SD card may be problematic.

Some SD cards are not genuine or have a lower capacity than advertised. Some simply fail over time.

Symptoms of SD cards not working correctly are:

  • Read-only behaviour, or changes made not persisting
  • A filesystem corruption error

Symptoms of counterfeit SD cards are:

  • Writing works until a certain filesystem size is reached, thereafter, writes seem to cause issues where existing data is lost or newly written data is not preserved.
  • SD card fails after a short amount of time.

Counterfeit cards are usually found on Amazon and eBay.

SD cards have a limited lifespan. I recommend you change SD card and suspect that issues will no longer persist with a good card. If you would like to be a good quality SD card purpose manufactured for OSMC, then you can find one in the Store.

Thank you Sam,

I was using this SD card for 2-3 years with the same PI, then in August system failed andI decided to install new version.
So maybe this card has just failed after long usage as you suggest.

I will get another one and give it a try. I will inform here if it was a success.

Thanks for help.

  • Piotr

You were right Sam, I have checked the SD card by the SD Formatter and the card is dead.
I ordered new one.
So this case is closed.