Cannot install Samba


I’m running OSMC 2020.06-1 clean install, and trying to reinstall Samba which worked great earlier on same version, but now I can’t install it. Tried app-store first but didn’t work, said all packages weren’t installed. So tried SSH by first doing “sudo apt-get update”, reboot, then “sudo apt-get install smb-app-osmc” but then getting “E: Unable to locate package smb-app-osmc”.

Please advice.

You would need to provide some logs
grab-logs -A
And provide the URL

Oh, just read now that you are on an old version. Guess the package is not compatible anymore and you would need to install smb server yourself and configure it.

Would it be possible to install the old package that I used before and that worked fine?

I doubt you have a copy of it, or?
Anyway it normally should work so please provide logs to see what is wrong.

No, I don’t have a copy of it. I guess I was wondering if it’s possible to find an old version of it, but maybe not.

When using “grab-logs -A” I get an error message saying it can’t upload the logs:
Exception Details:

Traceback (most recent call last):
File “/usr/bin/grab-logs”, line 836, in dispatch_logs
raise ValueError(‘Upload Returned Empty String’)
ValueError: Upload Returned Empty String

Failed to upload log files, copying to /boot instead. (Unable to verify)

In /boot I find “uploading.txt” but that file tails with some events from yesterday, so it seems the failed installation of samba (that I just retried) wont write anything, at least not to the end of that file.

Any other idea? Is it possible to upload “uploading.txt” any other way?

Does your machine have an internet connection?

Yes, streaming works well in Kodi for ex.

Ok does grab-logs -a work (lower case a)?
Otherwise let’s do one by one, copy/paste output of:
cat /etc/apt/sources.list

No, I get the same Exception as with -A

deb Index of /debian stretch main contrib non-free

deb Index of /debian stretch-updates main contrib non-free

deb stretch/updates main contrib non-free

deb stretch main

We only support one upstream distro previous to maintain an upgrade path. This means that we currently support Buster, Bullseye only.

You may want to migrate to a newer version of OSMC. The samba package we provide is a meta package however and just bundles the upstream version of Samba with some overrides, so you could replicate the changes it introduces trivially, but unless you have a reason to remain on an older version, I’d suggest upgrading.


1 Like

Yes, unfortunately upgrading is not an option, since the later versions of OSMC introduced an unresolvable problem with video playback, detailed in this post Vero2 crashes when stopping or seeking h264 - #51 by olorin_75

I’m sorry, but I don’t understand at all what this means…I’m not even able to install any samba package.

On this same topic, is there any other way than samba of transferring files from my vero2 to a windows client on the same LAN?

So what is the error displayed after apt install samba-common?

You could easily use SFTP (e.g.on Windows via WinSCP)

No error as far as I can tell:

osmc@osmc:~$ sudo apt install samba-common
Reading package lists… Done
Building dependency tree
Reading state information… Done
Recommended packages:
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 120 not upgraded.
Need to get 175 kB of archives.
After this operation, 1024 B of additional disk space will be used.
Get:1 stretch/updates/main armhf samba-common all 2:4 .5.16+dfsg-1+deb9u4 [175 kB]
Fetched 175 kB in 0s (2014 kB/s)
Preconfiguring packages …
(Reading database … 24378 files and directories currently installed.)
Preparing to unpack …/samba-common_2%3a4.5.16+dfsg-1+deb9u4_all.deb …
Unpacking samba-common (2:4.5.16+dfsg-1+deb9u4) over (2:4.5.16+dfsg-1+deb9u2) …
Setting up samba-common (2:4.5.16+dfsg-1+deb9u4) …]

So then you were able to install the samba package.
You then would just need to configure your shares in /etc/smb.conf and should done.

I made that /etc/smb.conf and put in the following:

workgroup = WORKGROUP
path = /media
read only = no
guest ok = yes

Then rebooted, but my windows client can’t see OSMC on the network. How can I verify that Samba is up and running?