Cannot load widevine?

This is in the log:
2020-10-15 17:25:18.055 T:3348075232 ERROR: [script.module.inputstreamhelper] [u’ldd’, u’/home/osmc/.kodi/cdm/’] cmd failed.
2020-10-15 17:25:18.056 T:3348075232 ERROR: [script.module.inputstreamhelper] Failed to check for missing Widevine libraries.

Happened overnight with no changes that I know of. Should I reinstall widevine and if so how?

This probably isn’t an OSMC problem, I think there should be some info on inputstreamhelper’s github page, else an issue should be created.

But to be sure i’ll check my Vero4k, and try to install Netflix addon on my pi3. There might be an issue for me since i’m running OSMC Buster testing on both of them.

1 Like

OK. Anything I can do to help stroubleshooting? I am sure it worked day before yesterday.

osmc@osmc:~$ ls -l /home/osmc/.kodi/cdm/
-rwxr–r-- 2 osmc osmc 9331116 Oct 2 19:23 /home/osmc/.kodi/cdm/

Try this, settings on Netflix addon -> Expert -> InputStream Helper Setting… -> (Re)InstallWidevine libry

Power (main menu) -> Exit

And try start your addon that gave that error to begin with. (guessing it was netflix)

Yes, netflix. Will try that.

Edit: Worked. Thanks!

Hello all,

I have this same issue, here is the log file:

I tried all the things @joakim_s suggested, but to no avail/ I SSH’d into OSMC and the .so is there at the location it wants to see it, but still gives the error.
Can anyone give me a pointer to how to resolve this issue.


If this is a new install, this answer doesn’t apply. But under inputstream.helper you got restore old libwidvine.

Saw in netflix-addon issue thread on github, that it’s not a netflix issue, but rather google has done some update to the arm version of the .so file, it’s like 1 mb larger then the previus version. last working had a version number ending at .77 I belive.

Srry, I just picked this thread just to get my problem out there.
I just picked up on the issue on Github. I hope they fix the problem, because from what I read all previous versions of Widevine are going to stop functioning in about 3 weeks and the new one has a problem as well. As you stated, this is a new install, so I don’t have an older version as backup. But even if I am able to source an older version of Widevine, Netflix( or any other streaming service with Widevine) will stop working on Kodi in about 3 weeks…

I do have to mention that this is not a problem related to the Netflix addon, but an addon that it needs: Inputstream.Adaptive

Can you post the output of this command:

ldd /home/osmc/.kodi/cdm/

you are downloading the version ‘Downloading best ChromeOS image for Widevine: FIEVEL (13816.64.0)’
seems to be the bug with the latest widevine library