Cannot mount a NFS share

Hi Guys

I cannot mount a NFS share.

Logs here:

showmount -e shows:

osmc@osmc:~$ showmount -e
Export list for

fstab file:

osmc@osmc:~$ cat /etc/fstab
# rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/vero-nand/root  /    ext4      defaults,noatime    0   0 /mnt/NAS-Movies nfs noauto,x-systemd.automount 0 0

Any thoughts?


Moved you post to a new topic, to keep the wiki posts tidy.

Does it mount if you issue the following command:

sudo mount /mnt/NAS-Movies

If it does, try enabling wait for network in MyOSMC.

Thanks Tom.

1 Like

Have you tried mounting it manually ?

mkdir /mnt/test
mount -t nfs /mnt/test

To see if you can mount it.
The one thing I never do with NFS target/directories is using any special char in the directory.

I havent… but just did.

osmc@osmc:/mnt$ sudo mount -t nfs /mnt/NAS-Movies
mount.nfs: access denied by server while mounting

So - you have your answer there. Check your Server settings

Sorry im not really familiar with UNIX :confused:
What would I check Smurphy?

exports file?

It has this:


So that gives access to IP but your OSMC is

1 Like

Thanks! didnt realise thats the CLIENT IP thats needed, not the server IP.

Its working now. Sorry for wasting your time

No worries, education is never a waste of time. :grin:


BTW - what is the IP of the Server, and what is the IP of the Kodi-client? Maybe that’s what is wrong?
Update: saw that this was already dealt with, while I wrote it down :smiley:

1 Like

Yep its visible in the SSH Client.

How do I make this share visible inside the GUI so that I can browse its movies?


browse to root filesystem, mnt, NAS-Movies

Thanks Tom.

1 Like

Thank you

1 Like