Cannot pair Bluetooth keyboard with Vero 4K (APLIC 303324

Hi, I bought a bluetooth keyboard from ebay. I can get it working on other devices but I can get it to pair with my computer, but not with my Vero 4K.

This is the keyboard manual (in German): APLIC 303324/20180622SZ140 BEDIENUNGSANLEITUNG Pdf-Herunterladen | ManualsLib

Vero sees the device in bluetooth discovery mode. The keyboard requires a pin in order to pair but when I select “Connect with Pin” after a few seconds I get the message “Connection to Aplic-303324 failed”.

When I select “connect without pin” the keyboard works for a few seconds and then disconnects.

If anyone has any ideas for me I will be very grateful.

Thank you


I’d check out this how to and try it via the terminal…

hey. thanks.

that link is mainly about bluetooth audio, which seems a bit of a different ballpark to what i am dealing with. but i think you’re right. I need to figure out how to pair a bluetooth keyboard from the terminal.

Yes that is about audio but steps are the same. The crucial one is to “trust”

1 Like

Hey there. Yep. You’re right. This worked and I was able to pair the device with a pin and trust and connect to it.

Unfortunately the keyboard and osmc do not automatically make a connection on startup, so I have to do that from the OSMC settings. It works now from there, but is there anyway for the the keyboard and vero just to see one another automatically?

Thank you!

With my keyboard, I just have to hit some keys a few times to re-establish the connection, so try that. You could run a script at start-up but after a while the KB will go to sleep. If Vero kept re-connecting your KB battery wouldn’t last long.