Cannot see USB thumbdrive after osmc install

HI everyone,
Recenty I tried to upgrade my nov2016 ver of osmc using the online osmc tool within osmc. After it installed and upgraded I had issues so I decided to install it from scratch .

USB stick is a Sandisk Extreme 16GB USB3.0

I ran the osmc installer and it all went fine first time. I installed the latest version of osmc available, chose USB as target and worked fine. Once I booted in osmc however, i tried to recover my settings from backup(my nov 2016 osmc version backus) and had issues restoring everything. Errors and didnt bring my movies etc.

SO i decided, screw it, i will start from scracth again, won’t restore from my backups. I will reconfigure everything from scratch.

Hwever upon trying to run the osmc installer again I found that it no longer sees my USB thumbdrive. I can see that Windows now sees my thumbdrive as a HDD ie not removable.

Has anyone seen this before and is there a fix?


Not sure if you in the progress of your reinstalls mixed up things. You always install to the SD Card. And only by choosing USB as the target the installer (on the SD Card) will write the root file system to the USB Stick.

hmmm, the installer asked me if i want to install it to sd card or usb and some other options. I chose USB and pointed it to the USB stick. Could that be my mistake? If so how can i recover my usb stick to become normal so its seen as a removable usb stick?

Ok maybe my mistake for which target device do you install?

I asked for USB target and pointed it to my Sandisk Extreme 16GB stick.

I meant Raspberry Pi, Apple TV or Vero

Raspberry Pi 2/3

Than means even you choose USB install you would install the boot partition and installer onto the SD card.
You then plug SD card and USB Stick into the Raspberry Pi and boot it

ok so even though i chose usb, i should have let it install it on the sd card. Then plug both sd card and usb stick in pi on bootup.

So question remains then. My usb stick is now no longer appearing as a removable flash device. How can i possibly fix it?

btw: thank you for your help


My suggestion try the above and based on the outcome we check that problem

So yes, trying the above works as far as installing and running osmc. However it seems my usb stick has been turned into a device that from now on is recognised as a hdd rather than a removable device. Oh well, I don’t care. I will just use it for osmc.

I have some other problems in osmc now like “unable to connect to remote server…” when scanning for content but I ill dig around on forum first for answers. My pi is connected to internet so I don’t know.

Thank you for your help fzinken.