Cannot SSH into Vero 4K

#1

Hi. Has anyone encountered not being able to ssh into Vero 4K? I’m using PuTTy. Vero 4K version 2019.06-1.

SSH service is running. I just type in the IP address in PuTTy and select ssh. Error message is “no route to host” or something similar.

I tried pinging, it says, “Destination Host unreachable”

Log is here: https://paste.osmc.tv/opejubayev

Reaching the command prompt via usb keyboard (power -> exit) works.

Any ideas what’s happening?

#2

How have you set up networking on your Vero and the computer? Did you statically assign the address or did you let the router assign you an address? I suspect a misconfiguration in the network settings.

#3

Can you confirm you’re trying to SSH to 192.168.55.85?

Is SSH enabled?

#4

That’s nothing to do with SSH. Basic network issue.

1 Like
#5

No route to host often means that your computer, that you run ssh from, is having issues getting to default gteway.

#6

yes. I downgraded to 2019.05-1 and ssh worked

#7

probably not. I downgraded to the May image and ssh worked. nothing changed on my PC

#8

I think if SSH was broken we’d have some other reports.

Brave enough to update?

1 Like
#10

Will do that and report back. Thanks!

#11

updated now and ssh works. thanks @jb2cool @sam_nazarko @joakim_s @fzinken

#12

Sorry. Same problem again.

Attaching photos

#13

Start with simple network troubleshoting

  1. ping 192.168.55.157 from PC
  2. ping from Vero
  3. ip ro from Vero
  4. route PRINT on the PC

Also try to disable IPv6 on the PC is it is active.

#14

@fzinken Sorry.

  1. What’s the syntax for ip ro? Do I just type ‘ip ro’ on the command prompt?
  2. About route PRINT, do I just open the command prompt and type route PRINT?

Results so far:

  1. Ping PC to Vero: Destination Host Unreachable
  2. Ping Vero to PC: It just outputs 1 line "Pinging " then nothing happens for a long time. I need to Ctrl-C to cancel
  3. IPv6 is disabled.
#15

Seems like there is a vary basic network issue between the PC and the Vero. Have you tried rebooting the PC? From the PC can you ping the router (may be 192.168.55.1, but you’d have to verify that). And can you ping it from the Vero?

#16

@bmillham. Rebooted. Problem persists.

  1. Ping Vero to router works.
  2. Ping PC to router works too.

by router, I mean 192.168.55.1

#17

On the router, does both the PC and the Vero show in DHCP?

Try rebooting the router also. And is it possible to connect the Vero directly instead of using WiFi?

One other thing to try from the Vero, run traceroute <ip.of.pc>

#18

@bmillham thanks for your help. I’ll do those tomorrow.

#19

Yes

yes

I really suggest you grow some confidence and just try such things :wink:

You can also check the Arp table (after you tried to ping the PC, Vero and router) with arp -a.

1 Like
#20

thanks @fzinken! I will try to grow a pair :rofl:

@bmillham Rebooting the router, PC and Vero didn’t do the trick

I found out what’s wrong now. Thought about what Sam said earlier in this thread. “if SSH was broken we’d have some other reports.” So it must be a situation unique only to me, and it is. I was using a slightly modified image from way back 2018.12-1 and from there update to 2019.06-1.

But when I use the image from the OSMC website, SSH is working as expected. Thank you, @fzinken & @bmillham. Sorry I didn’t suspect this before. :sweat_smile: