Cannot update OSMC


I am having an issue where I am unable to update OSMC. There are other issues as well (“mark as watched” flags not working), but I thought I would tackle one thing at a time.

Logs have been uploaded here:

Thank you for your help, and let me know if you need additional info.

Your apt cache has an issue

14:19:19 96.444389 T:1788613616 DEBUG: script.module.osmcsetting.updates : - apt_updater encountered and error:
Exception : Error Type and Args: SystemError : (“E:Malformed Description-md5 line; doesn’t have the required length (32 != 54) ‘bcb487f8b6786f2b27b8eb25e8d885d7518962998c0dc6b17e1dd2’, E:The package lists or status file could not be parsed or opened.”,)

My first usggestion take down that overclocking and overvoltage setting. But you might still have a file corruption.
Try sudo apt-get update and sudo apt-get dist-upgrade and report results.


The overclocking settings are the “default” ones offered by OSMC. I thought they would be ok, especially since I am using the power supply offered on this site. I changed the setting back to “Normal”

This is what I got after running what you suggested:

Running sudo apt-get update:

W: Failed to fetch Hash Sum mismatch
E: Some index files failed to download. They have been ignored, or old ones used instead.

Ran sudo apt-get dist-upgrade. As described in other update related threads, I think apt-get autoremove removed apt-transport-https. I will have to check whether I have any custom repositories installed that need it. Other than that, it seems to have worked.

I am running version 2016-02-4 right now.

Interestingly: I ran the updater from withing OSMC after running the two commands, and now it progresses further. However, at first it attempts to download Translation-en (and some other packages). Then I receive the notice that no updates can be found. If I repeat the scan for an update, this happens again.

That suggests a problem with the Debian mirror that serves your country. Where are you located ?

It will probably fix itself in a day or two when they discover and fix the problem.

Where are you located ?

I am in Austria. Is this something that is causing the other issues that I am facing?

Nope. It will only be causing errors trying to update.

I ran sudo apt-get update and sudo apt-get dist-upgrade again, and this time did not receive the error messages.

I guess I’ll have to wait until the next update is released to find out whether the updater in My OSMC is working?