Cannot update - unknown package


I just got the unknown package error during update on my pi3.

Logs here:

It looks like a file corruption:

files list file for package 'liblzma5:armhf' is missing final newline

File /var/lib/dpkg/info/liblzma5:armhf.list should look like this:


You can try to edit it and copy/paste the above data.

Alternatively, delete it, and reinstall liblzma5

sudo rm /var/lib/dpkg/info/liblzma5:armhf.list
sudo apt-get install --reinstall liblzma5

then continue with the upgrade:

sudo apt-get dist-upgrade
1 Like


Thanks for helping.

I tried reinstalling liblzma5, but then the same happened to another package; libpng12-0:armhf. And when I reinstalled it, another package failed. And so on.

What is causing this? My installation is working fine, it just won’t upgrade.


Either the card is failing or there were some problems during the update that caused various filesystem corruptions.

You can try to repeat the delete/reinstall process but, realistically, there will very likely be other corrupt files lurking out there. I would therefore recommend that you back up all your settings and perform a fresh install, ideally on a fresh card, though that’s your call.

Same problem (unknown package) with my Pi 2.

Without logs there is no way to tell if this is the same problem or package. Just the same symptom.


Thanks for the help.

I have now reinstalled on a new and better SD-card.
Backup/Restore of settings worked like a charm.



I’m having the same problem with the update, but in order to get the maximum information possible, where can i find the log of the update process?

Thanks in advance

You can post logs on this forum and perhaps we’ll see what the problem is.

The APT logs can be found in /var/log/apt.

The command grab-logs -a will provide a link to your apt logs easily.

I’m getting a command not found.

On the log folder i can see some term.log and history.log

Try paste-log /var/log/apt/history.log

No success again, command not found

I can upload the file to somewhere if i know wich file to get

The failure of these two commands are often indicative of a bigger problem, being filesystem corruption. It’s not a good sign.

If you are able to read the files from an ssh session, you can simply copypaste them to . After you save there, you can provide the resultant URL.

Here goes my log:
I’m sutck on OSMC version 2017.10-1

Thanks for the help locating the log file

Comment out or remove the moonlite repo from your sources list and try updating again.

Must advise though:

Start-Date: 2017-05-29  11:39:32
Commandline: /usr/bin/apt-get-real install -y --no-install-recommends lsb-release
Install: lsb-release:armhf (4.1+Debian13+nmu1)
End-Date: 2017-05-29  11:39:37

attempts like this, are not going to work out well for you in OSMC.

Thanx, it solved my problem at that time.

Now after a clean install, without moonlight i cant update again.
I’ve just installed some video addon.

Here goes my log:
I cant see any thing strange here… i could use some help

That log shows no attempt at an update. So full debug logs could be helpful, especially since you say: I’ve just installed some video addon.

And what if you:

sudo apt update
sudo apt dist-upgrade

from command line?

I’ve not tried to update the system from command line, it showed up the message saying that osmc had downloaded some update, asking if i wanted to do the update…
And during the process, came the message: Cannot update - unknown package

So please try what I suggested.