Cannot update Vero4K+ & overscan/subtitles won't be remembered

I cannot update because of an error. Never been able to since I bought it.

Here is the log:

Also, changing the overscan settings (video calibration) & subtitle position are never saved.


Start-Date: 2019-10-24  22:07:24
Commandline: /usr/bin/apt-get-real install build-essential rbp-userland-dev-osmc libvncserver-dev libconfig++-dev unzip

This is why you are having issues with updating, you probably wanted to install:


The fix:

sudo apt-get purge rbp-userland-dev-osmc
sudo apt-get update
sudo apt-get dist-upgrade
sudo reboot 0

If the overscan settings issues persists after this, please let us know.

Thanks Tom.

As @Tom_Doyle wrote seems you tried to install packages that are for the Raspberry not the Vero. So you need to try to purge that pages which should allow you to update.
Looks like you wanted to install VNCserver. For the Vero there is a different solution for the VNCserver, there is a respective thread here in the forum.

Last but not least overscan generally should be avoided as it hampers the picture quality. Normally there is a setting on the TV to avoid the need of overscan unless you use a special display.

Thanks! I did, and I got it working, but it’s true I tried the pi package by accident first. Didn’t know you had to purge it.

I agree with overscan, but for some reason osmc keeps falling out of my screen, while no other device does that. I’ll go through my tv settings again.

Update succeeded. Thanks so much for the quick help… should’ve just came to the forum straight away instead of waiting 2 months :slight_smile:

1 Like

What’s the make/model of your TV?

Actually just saw you have your GUI configured with 4K, we recommend to keep the GUI on Full HD for smoother operation

LG C8. It’s supposed to be fixed by the “just scan” setting.

But the thing that annoys me the most is subtitle location won’t be saved. It probably has to do with running the GUI in 4K/60hz, and movies in 1920/different hz (adjust hz to movie framerate is enabled).

As I wrote that is not suggested

To me it seems very smooth, running the GUI in 1080p on a 65" is not really pleasant :slight_smile: But if there’s so many problems with that i’ll switch

As most likely every LG C8 owner in this forum will confirm the TV will do a good upscaling job of the GUI so it should be not looking differently.

1 Like