Can't access http server of kodi on port 8080

Hi,

My kodi box is running on raspberry pi. It use been updated to version 2017-01. It uses a Fixed IP address (192.168.1.10) that I can ping. I can’t ssh anymore to osmc and from time the time the yatse client - krypton is disconnected. This problem doesn’t happen regularly but is really annoying. I can’t even access the http Web Server at this address : http://192.168.1.10:8080/ even if the Http Server - Remote Access is enabled.

What could be the issue(s) and suggestions to resolve that ?

Many thanks in advance for your help

Charles

Hi,

Please provide logs:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks Tom.

Hi Tom,

Here is the log uploaded from osmc on the SD card : gist:934d16070320d0d44ba49beb90572c20 · GitHub

Regards

Charles

Hi,

Jan 20 12:21:21 osmc sshd[397]: Server listening on 0.0.0.0 port 22.
Jan 20 12:21:21 osmc sshd[397]: Server listening on :: port 22.

So it looks ssh is up and running, what ssh client are you using.

Have you tried access the http server on port 80?

Thanks Tom.

ping 192.168.1.10
PING 192.168.1.10 (192.168.1.10): 56 data bytes
64 bytes from 192.168.1.10: icmp_seq=0 ttl=128 time=4.542 ms
64 bytes from 192.168.1.10: icmp_seq=1 ttl=128 time=2.370 ms
64 bytes from 192.168.1.10: icmp_seq=2 ttl=128 time=2.517 ms

I try to ssh from a MacOS machine

ssh -vv osmc@192.168.1.10
OpenSSH_7.6p1, LibreSSL 2.6.2
debug1: Reading configuration data /Users/dabou/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 48: Applying options for *
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to 192.168.1.10 port 22.

Within Google Chrome, I can’t access the Web Server using the following URL :

I’m also trying to use use curl without success

  • curl --header ‘Content-Type: application/json’ --data-binary ‘{ “id”: 1, “jsonrpc”: “2.0”, “method”: “Player.GetActivePlayers” }’ ‘http://192.168.1.10:8080/jsonrpc

To access osmc using “Kodi Kripton” remote client, I have to reboot my android mobile

Hi,

Dilthedog has just spotted this:

Jan 20 12:21:38 osmc http-time[295]: Unable to set time using HTTP query - no response received from servers.

Are you able to ping your router from your pi?

Also it may be worth trying a different network cable or port on your router.

Thanks Tom.

As I can’t ssh anymore to the osmc - raspberry box, I can’t check if it can access the router.

I confirm that I can use the option “Update OS” within the menu of OSMC and this is what I did last to update it to version 2017.12-1.

I will try to reinstall it and as you suggested use a different ethernet cable

Hi,

You can access the commandline via power and exit and using keyboard keeping pressing the escape key. You should be presented with a console prompt. more details can be found here:

https://osmc.tv/wiki/general/accessing-the-command-line/

Thanks Tom.

I have reinstalled osmc and I don’t expriment such problems anymore. I can ssh or use also the web browser.
Many thanks for your help

glad to hear its sorted.