Can't access My OSMC - Blank message, and other problems


#1

Whenever I try to access My OSMC, I just get a blank pop-up message, with a button to click Ok.

I’ve tried to Upgrade to the latest version (via SSH) and the problem continues. I’ve also tried to change the skin, but when I try to do that in settings, I click in “Estuary” but nothing happens, no button to choose other skin, nothing. I tried to change it via GUI Settings.xml, but I still could not access My OSMC, the same blank message appeared.

Additionally, I also can’t install any add-on, it says it couldn’t install dependencies or something, but I did not include that in the logs because I want to try to solve the My OSMC first and then see if I can resolve the add-on issue.

Here are the logs: https://paste.osmc.tv/inukurefup

I should add that I use OSMC on a Raspi in conjunction with a Synology NAS which has all the media and connect to it using MySQL databases and NFS shares, however one of the HDD has recently failed and I’m in the process of replacing it, so that’s why Kodi cannot access any of the media shares and the like. Just to justify some of the errors I see in the logs.


#2

Hi,

Couple of things:

20:52:05.773 T:1925556736   ERROR: SQL: [Addons27.db] The database disk image is malformed
                                            Query: PRAGMA cache_size=4096
20:52:05.774 T:1925556736   ERROR: Connect failed with 'SQL: [Addons27.db] The database disk image is malformed
                                            Query: PRAGMA cache_size=4096

Removing Addons27.db and restarting kodi, the database should be recreated.

0:52:21.261 T:1905259264   ERROR: Unable to open database: VideosM85 [2003](Can't connect to MySQL server on '192.168.1.77' (111 "Connection refused"))

Kodi seems unable to access your mysql server, I would look into this as well.

Thanks Tom.


#3

Hi, thanks for the answer. Yes, I know it can’t access the database because the HDD where that was installed on the Synology NAS was the one that failed and I’m in the process of replacing it.

That’s why in the meantime I’m trying to temporarily use OSMC in other ways.

But is the MySQL database being inaccessible the reason why My OSMC doesn’t open? Or the reason for the other problems?


#4

The problematic Addons27.db is probably the reason. Delete it, restart, and try again.


#5
20:57:34.590 T:1925958144  NOTICE: Old database found - updating from version 20 to 27
20:57:34.591 T:1925958144   ERROR: SQL: Can't copy database. (11)
20:57:34.591 T:1925958144   ERROR: Unable to copy old database Addons20 to new version Addons27

It looks like there’s also an Addons20.db file. Delete that, as well.


#6

So I’ve deleted the files and I also had to delete advancedsettings.xml where the info to connect to the MySQL database was, but I finally could access My OSMC, and I can now change the skin through the interface as well. However, I still cannot install any addon, as it keeps sayinf it failed to install dependencies.

Since I do not have much time at the moment and since I can now preform backups through My OSMC, when I have the time to replace the failed HDD on the NAS and put everything back the way it was, I will also just reinstall OSMC from scratch, maybe simplifying my setup a bit.

Thanks a lot for your help and for answering so quick to my post!