Can't access my samba shares

Hello, I have received a new update yesterday and now, with Vero 4k, I can’t access my samba shares; they are all smb1 shares because it is a very old NAS. Could anybody help me, please?

Have a read of: File sharing with a NAS, media server, windows share or other device - General - OSMC.

Ok, I’m going with it, but is there any change related on yesterday’s update?

There hasn’t been an update since March.

This is ready weird, because I received an update yesterday. How could I check which channel an I using?

You can post some logs via My OSMC.

https://paste.osmc.tv/icororuxij

You have the staging repository updated and have updated to Debian 11 Bullseye. This is still experimental and there will be a testing thread soon.

Your APT sources.list shows:

deb http://apt.osmc.tv bullseye main
deb http://apt.osmc.tv bullseye-devel main

I’d suggest following the instructions in the Wiki.

Ok, sometime before I have had to switch and now I’m screwed. Is there any way to revert to factory default (and revert to Debian 10)?

I know how to factory reset the kodi part

$ sudo systemctl stop mediacenter
$ mv .kodi .kodisave
$ sudo systemctl start mediacenter

but how would I revert to previous debian build?

Ok, I will reinstall the latest image:

You need to reinstall from osmc.tv/download.

But Debian 10 will be end of life (from an OSMC perspective) soon.

I wish I wouldn’t need to reset, but all my collection is in samba and, if I can’t access, I can’t use Vero at all.

Don’t know if I could troubleshoot where is the problem.

If I try to access to my files I get “software caused connection abort”

Did you go through the troubleshooting in the article that Sam linked to about how to access files on a NAS? Your problem is probably related to the old version of SMB on the NAS. You can force a version when mounting.

Are you mounting via Kodi, fstab or autofs? I can’t tell for sure in the log that you shared. In fact, that log looks odd because from the output of mount it looks like they are mounted via fstab, but your fstab is empty.

It’s mounted through Kodi itself, I never thought to mount any other way but will try in the following days. Thanks for guiding me, I will report as soon as I try.

Did you check that in Kodi settings>services>SMB client>maximum protocol version> was set to SMBv1? I couldn’t see in the logs you posted as you didn’t upload the log that contained that information.

No, minimum of dry to none and maximum of dry to v3 to be able to read from V1 to v3.

Try setting the max to SMBv1 so Kodi does not try to use a newer protocol than your NAS can communicate with.

Ok, will try this evening, thanks!

Ok, mounted my shares sith autofs and now they work perfectly; last struggle is to combine smb and nfs shares this way

For @sam_nazarko, if it is useful, as you stated I’m using debian 11 and no problems but this smb issue (I’ve seen you started a thread).

Thanks!