Can't access samba share after September 2017 update


I have a samba server (with my movies). My Raspberry Pi connects to it to read movies. It was working like this for the past 3 years.
But yesterday I updated OSMC on my Pi and now I can’t access my samba server. In Videos > Files, I choose a share folder (that was working previously) and enter the password. I press “OK” but nothing happens. Then I press “Cancel” and see this message: couldn’t connect to network server

I tried from another computer (Windows10) to access the samba server and it is working as expected. So I believe the problem comes from OSMC.

I ran apt-get update and apt-get dist-upgrade but there is no new packages to install.

Here is kodi.log:
You will see the error messages at the end.

Please let me know if you need more information.

It would seem your problem lies here:

21:51:48.929 T:2634019824 ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://USERNAME:PASSWORD@RT-AC56S-8278/series' unix_err:'d' error : 'Permission denied'

The samba server is rejecting the request due to incorrect permissions.


I think the solution to your problem will be found in this topic:

Thanks Tom.

Thank you for the link @Tom_Doyle ! It seems to be exactly the same issue. I will try the fix tomorrow.


I’ve just been advised that setting the smb protocal to smbv1, via the kodi gui should resolve your issue.

Thanks Tom.

I tried smbv1 and also smbv2 but that didn’t solve the issue.

To solve the problem I created ~/.kodi/.smb/user.conf:
lock directory = /home/osmc/.kodi/.smb/
client max protocol = SMB2
name resolve order = bcast host
client use spnego = no
client ntlmv2 auth = no

Then I restarted the Pi and now it is working. Thank you for your help!