Can't access Vero 4K/OSMC from Windows

Ok, so in the Administrator Command Prompt (the path c:\Windows\system32 tells us you’ve managed to open the CMD as Administrator), what happens if you invoke

net use p: \\\osmc /user:osmc

replace P: with a drive letter not used?
I expect that you’re asked to enter a password, again. Hope you have reset the osmc password on the Vero using sudo smbpasswd osmc back to osmc.

Exactly the same (I use \Vero4k\osmc).

I hadn’t changed the smb password (only the SSH password) but I ran through the motions and set it again as osmc, using the sudo command you suggested. And then, this …


Mmmmhhh, that looks weird. On Windows, please do

arp -a

and paste the output in (by clicking the Save Icon you see a new URL in the browser’s URL field. This is the one you can paste here.)

On the vero do

ifconfig | paste-log
ip addr | paste-log

and provide the URLs you get back.

Assume you meant .123 (not .255)?

ip addr:

Thanks for your help this evening guys, I’m going to have to call it a night and pick this back up tomorrow.

Last idea I have is to re-add the osmc user to the samba db on the Vero

sudo smbpasswd -a osmc

(use the default password osmc)


If that is not working someone needs to follow up from here why the change of the password of the smb user osmc is not working.

No I meant the broadcast address
The both commands need to be invoked without too much time in between.

Thanks again, but that didn’t work either. In SSH the ‘new’ password (osmc) is accepted, as expected.

When trying to connect to the osmc folder from Windows, I’m still seeing the error message that I shared in Post 14, above.

Sorry about that! Here’s the output you asked for (100% data loss)

To get rid off this IPC$ hidden thing, try on Windows (Administrator Command Line):

net use \\\IPC$ /delete

Wow quite a few things happened since I last opened this thread.
So if I get it correct:
net view \\ is working and shows the two shares of the OSMC box, correct?
net use p: \\\osmc /user:osmc gives you “password is not correct”

I am not sure if we really get here to anything, especially as the trigger for the issue is not clear but I would suggest two tests:

  1. As you seem to also have a Openelec machine running can you still access that from the Win10 PC? Also can you from the Openelec machine access the Samba Share on the Vero?

  2. Try to increase the min protocol on the Vero server:
    sudo systemctl stop samba
    sudo nano /etc/samba/smb-local.conf
    than add this line server min protocol = SMB2_10
    sudo systemctl start samba

Morning @JimKnopf I tried that last night, and again this morning. cmd reports it was successful, but rerunning net use shows the IPC$ is still active.

See the first dump at

@fzinken Thanks for the additional suggestions.

  1. Yes, I was able to access the Openelec machine from Windows. I didn’t have chance to check if I could access the Vero from Openelec - will do that this evening, if the following is of no use …

  2. Did as suggested, but on restart of samba I encountered all sorts of errors. I’ve copied the responses I got back in the SSH window, and it looks like the Samba service could be at fault?

See from line 55 onwards

Thanks guys, got to run to work. Will pick up again this evening!

This is now strange as it was working before.
So first maybe undo your current change and try again
sudo systemctl stop samba
sudo rm /etc/samba/smb-local.conf
sudo systemctl start samba

Ok seems we need to do some testing how to put it into smb-local.conf.
For now do:
sudo systemctl stop samba
sudo rm /etc/samba/smb-local.conf
sudo nano /etc/samba/smb.conf
than add this line server min protocol = SMB2_10 into the [GLOBAL] category
sudo systemctl start samba

1 Like

Thanks @fzinken. Will give this a go after work.

No joy, I’m afraid. Followed your suggestions, still seeing the same error message in Windows Explorer, and when trying to map the folder using cmd I’m still seeing error message: System error 86 has occurred. The specified network password is not correct.

I was able to successfully remove the \IPC$, but still the same issue. and \IPC$ returns every time I try and login using Explorer.

I also tried browsing from an openelec device on the same network. Browsing to the \vero4k\ and manually browsing to \\osmc both gave ‘Error. Connection Timed Out’ (displayed almost instantly, whereas I was able to browse to all other devices on the network from the openelec device).

So, it looks like the issue lies with the Vero4k?

So how do I reproduce this?

Install Windows 10
Install Samba server on Vero 4K

Try and access a share on the Vero 4K?

  • using kodi or fstab?
  • if fstab, what does fstab look like?


We are talking about Win10, so going \\IPaddress\sharename in the explorer bar ought to do it.

Hey Sam. I guess so, but it was working fine just a few days ago so I would also guess that you wouldn’t run into the same issues.

I can access smb shares on my NAS from Vero 4K no issue. I can access fstab smb shares from Vero 4K no issue.

The only thing I can’t do is browse into the osmc folder from Windows SMB (and now also proven that I’m facing the same issue when trying to browse to the same folder from another kodi (openelec) device on the same network.

And that’s exactly how I would ordinarily browse (and map a network drive) to the device, previously.

Without doing too much scrolling - have you yet tried re-installing samba server? I don’t know if removing from the AppStore does a deep clean but sudo apt-get remove --purge should do it, followed by a check on any smb.conf files.

Nope, I don’t think so. Can you talk me through the exact code I’d need to run?