Can't access Vero 4K/OSMC from Windows

I’m having a completely stupid moment, and just need someone to point me in the right direction.

I previously had the osmc folder mapped as a network drive in Windows 10. Been messing with my PC and NAS, and the IP for Vero 4K has changed.

Type \\ and I can see the osmc network folder. Go to access it, and I can’t. I’ve tried osmc/osmc, and my Windows login details.

I can access the Vero 4K from SSH, default login osmc/osmc. I’ve also tried passwd and changed it successfully, but I still can’t connect to the folder from Windows.

I’m sure this is going to be a really straightforward fix, and I’ll probably kick myself, but am I missing something really obvious?

I’ve also tried using the nirsoft network password utility, but it doesn’t show me any details, despite supposedly working on Windows 10.


You should be able to connect from Windows Explorer with the default login (osmc/osmc) on WIndows 10 with \\ assuming is the correct IP.

Just tested it with both of my Vero 4k and it worked fine.

1 Like

Well, try to start the Windows credential manager and remove any old entries for the Vero 4k in the Windows Login Information.
Re-accessing the Vero 4k network location from Windows should then let pop up a new window where you can re-enter the login credentials, again.


Thanks for your suggestions, @thansen_dk and @JimKnopf. I’ll take another look this evening after work. It would appear there is something else at play here, as I did think that osmc/osmc should allow access. I’ll try removing the credentials, as you suggested. Thanks guys!

Nope, didn’t work. I can’t get my head around this. I thought it might have something to do with having added a USB3/Gigabit LAN adapter into the mix, and I could see two instances of ‘Vero 4K’ appearing in the LAN list in my router setup, plus I’d previously set a static IP against the adapter. So, I removed the static IP, removed the LAN adapter, removed the credentials as suggested, and confirmed I could still SSH to the Vero (via, as above). But I’m still not getting access to the osmc folder via Windows. @sam_nazarko Any ideas?

I’ll take a look at this tomorrow. It’s a bit late here



Cheers Sam, appreciate the quick response. Have a good rest!

Let me jump in while @sam_nazarko takes a deserved rest

  1. Login the Vero via SSH and run (and post URL’s):
    grab-logs -A
    route | paste-log

  2. Then run these commands and paste the output here
    smbclient -L localhost
    testparm -v | paste-log


Thanks for jumping in @fzinken. I’m at work at the mo, but I’ll do this once I’m at home this evening and update as suggested.

Hey there. See log output as suggested below. It was a little odd that when running smbclient -L localhost I was asked to enter osmc’s password, but it wouldn’t accept the one I’ve recently changed to (the same one I used successfully to start the SSH session). It would only accept the default ‘osmc’. Is that expected?

grab-logs -A
route | paste-log

smbclient -L localhost

Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.5.12-Debian]

        Sharename       Type      Comment
        ---------       ----      -------
        osmc            Disk      OSMC Home Directory
        IPC$            IPC       IPC Service (Samba 4.5.12-Debian)
Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.5.12-Debian]

        Server               Comment
        ---------            -------
        RASP2OPENELEC        OpenELEC
        VERO4K               Samba 4.5.12-Debian

        Workgroup            Master
        ---------            -------
        WORKGROUP            RASP2OPENELEC

testparm -v | paste-log

Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[osmc]"
Processing section "[automount template]"
Can't find include file /etc/samba/smb-shares.conf
Loaded services file OK.
This warning is printed because you set one of the
following options: SO_SNDBUF, SO_RCVBUF, SO_SNDLOWAT,
Modern server operating systems are tuned for
high network performance in the majority of situations;
when you set 'socket options' you are overriding those
Linux in particular has an auto-tuning mechanism for
buffer sizes (SO_SNDBUF, SO_RCVBUF) that will be
disabled if you specify a socket buffer size. This can
potentially cripple your TCP/IP stack.

Getting the 'socket options' correct can make a big
difference to your performance, but getting them wrong
can degrade it by just as much. As with any other low
level setting, if you must make changes to it, make
 small changes and test the effect before making any
large changes.


Press enter to see a dump of your service definitions

Yes, the SSH password and the samba password are two different passwords. The one for samba you change via smbpasswd.
Could that actually be your problem? Have you tried with osmc/osmc from windows machine?

Because the settings look correct

I see. Yep, I’ve tried using osmc/osmc and osmc/ (amongst other things!)

Is there a way to confirm the smb password hasn’t changed? (I haven’t actively changed it)

well it suceeded when you entered osmc?
Also you can sent it always to osmc with smbpasswd.

Also what does on your windows machine running net view \\ gives you?

D’oh, of course (osmc/osmc was successful for SMB password when logged in via SSH).

I tried net view (running as Admin) and got the following message: System error 5 has occurred. Access is denied. Everything I’ve just read about this error suggests the solution is to Run CMD as Admin (which is what I just did!).

Tried the old, switch everything off and back on. This time, when trying to browse to \\ I was asked for credentials, and the prompt accepted my Windows login details. The next screen shows the osmc folder (and a USB drive folder, which is currently plugged in to the Vero).

Again, trying to access the osmc folder (and the USB drive), every combination I’m trying is being rejected (osmc/osmc, osmc/, Windows user/password etc). For all combinations, the following is being shown, which suggests to me that it might not be strictly user/pass-related issue?


Completely stumped, but appreciate your help!

Reread now your post several times but still have no idea what you mean by that?

  • What is ‘old’ and what did you try?

  • What have you switched off/on?

BTW: I never ever saw this system error 5 running windows 10. Perhaps this has to be run with administrator caps, see here how to start such a cmd with a right-click:

FWIW, I set up a share on another Windows machine and net view \MACHINENAME works but net view \IPADDRESS does not. (error 5)

net view \IPADDRESS and net view \MACHINENAME both work on both devices running OSMC.

This is all without admin privileges.

Additionally, when I try to connect to the osmc folder via ‘Map as Network Drive’ I see this error:


Yet Credentials Manager is showing nothing against this IP address or folder.

Running cmd net use shows

image So, IPC$ (whatever that is) appears to be part of the issue.

Sorry, it’s late here, getting tired! I meant I’ve tried powering everything off, and back on in sequence (router, Vero 4K, PC) to see of that changed anything, but it didn’t. (The ‘old’ “if it doesn’t work, switch it off and back on again” IT support fix for everything!).

I’ve also tried running net view in cmd, and cmd with Admin Rights … same result for both.

Apologies, I stand corrected. Running net view (and net use) in cmd (non-Admin rights) is the only way it’s working. Odd. Net view is returning the following:


I was just wondering what happens if you try to connect using \OSMC (if that’s it’s name) rather than the IP address.