Can't add simple mp4 video to library

I just installed a fresh copy of osmc on a raspberry pi.

I have a single mp4 video file that I want to play when the device powers up and have it keep repeating it.

I have followed the tutorial on how to make the file. That works, but only plays the video once. I read that I have to create a playlist.

It appears the only thing you can add to a playlist is files that are in the video library. So I am trying to add the video to the library and can’t.

I copied the video file (video1.mp4) to a folder off the root called Movies.

I then went to the main menu and chose Movies.

There are no movies in the library, so it shows the button to go to files. I hit that button and it shows a list of folders.

I clicked on Add Video…

I Browse to the Movies folder I created off the root. It is now in the list.

I choose Movies for the “This directory contains”

I choose Local information only for provider.

I hit ok and now it is in the list.

When I go back to the main menu and select Movies the video still doesn’t show up.

I tried renaming the file “My Video (2017)” to try to follow the scraping format and that did not help.

If I go to the files area of the Movies source it shows video1.mp4 in the list.

If I right click it and choose “scan to library” it shows a progress bar for a split second and then shows the rename dialog. I tried all kinds of things in the name and when I hit OK it just shows the progress bar again for a split second and then the rename dialog again. Loop forever here. If I cancel then the video is still not in the library.

How do I add my mp4 video to a playlist so I can make it repeat over and over when the RPi boots up?

Why not place the video in /home/osmc/whatever? The problem is likely that the /Movies folder and files contained are not accessible by user osmc which Kodi runs as.

Sorry I was not clear. That is actually where the folder is: /home/osmc/Movies.

When I said root I meant the root inside of osmc, which starts at /home/osmc.

No you weren’t. Root is /.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

I hope this is the right place to reply. I read the link you gave and it said to make the support request in the support forums. I think that is here.

So the logs are uploaded here:

It appears there is something wrong with the ability to add a raw mp4 file to the movie database.

I decided to look into how to manually make an NFO file and did so. Once I did that I was able to right click and scan the file into the library.

You might want to pursue the problem above because it seems like you should be able to just add a file even without and NFO file, but as far as I go I have gotten past it my making the NFO file.

Thank you for your consideration and responsiveness.

Unlikely. This is specific to Kodi function, not OSMC. The Kodi wiki is very clear about the necessity of either an NFO file or use of an online scraper to provide metadata for creation of a library. Up to you whether you bring it up with them or not. Glad you got to a useful state though, enjoy.

Try adding it to the Videos library. Then Kodi won’t be looking for online metadata and the filename can be anything you want (with a suitable extension).