Can't boot on Pi 4 with external HDD

OSMC boots just fine when I don’t have my HDD connected, but won’t when it is connected. I was initially using Kodi which had worked just fine up till today, which is when I switched to OSMC. Any suggestions?

My guess would be power. Is the HDD powered via USB?

yeah, and it’s powered off the Pi. I’m really hoping that isn’t why it’s not working, especially since I didn’t have issues before

The Pi probably can’t supply enough power for the drive. As drives age, they draw more power. And as power supplies age, they supply less power.

Your best bet would be a powered USB hub.

yesss it worked! Thanks for the tip

So you had a powered USB hub on hand?

Glad to have been able to help.

I try to keep a bit of everything on hand just in case. As you can see, it helps sometimes. I was trying to power it off a built-in USB on my power strip, so I guess that just doesn’t have enough supply

Were you powering the drive or the Pi off the power strip?

The USB ports on power strips are designed for charging, not for powering.