Can't connect Bose QC35 to RPi3 (+ OSMC Bluetooth Adapter)


I’ve been trying to connect my Bose QC35 Headphones to my OSMC-powered RPi3, and I tried so many instructions on forums all over the internet but it just wouldn’t connect.

So I figured I’ll get the OSMC bluetooth adapter/dongle and that’s got to work. Connected it, restarted and same problem (would always say connection to bose qc35 failed). One problem here is that the RPi3 is defaulting to the on-board Bluetooth chip.

I followed one post here that says: “add dtoverlay=sdhost to config.txt”. I did, restarted, and it disabled WiFi too. So I removed that line. I’m totally lost and disappointed that even with the OSMC dongle I can’t get to connect these headphones!

Any help is appreciated, thank you.

Add dtoverlay=pi3-disable-bt to /boot/config.txt

Did you install ad2p app?
sudo apt-get install a2dp-app-osmc

Thanks everyone. I ended up buying a new smart TV with Bluetooth support so, that fixed it! :joy:
Feel free to close this thread but in case others have this issue, I’ll let it be now.