Can't Connect PS3 via Bluetooth

I have been attempting to use the ps3 controller via bluetooth. In particular I have tried to use this guide
[HowTo] Installing RetroPie alongside OSMC RC (the easy way):

I am able to use my bluetooth dongle

I am also able to pair the ps3 controller with my raspberry pi 2

However, when trying to pair with bluetooth I get an error about transport endpoint

And here is where I have been stuck for about a month.

You have an original PS3 controller?
The only thing I can find is about fake controllers: PS3 Controller and the PI - Raspberry Pi Forums

I have had the same issue with a fake controller and a real controller.

Unfortunately, right now running

results in

[quote]sixad-bin[16295]: started
sixad-bin[16295]: sixad started, press the PS button now[/quote]
and then a whole lot of nothing after pushing the PS button.

No idea, maybe Google for the error messages or look on the RetroPie forum.
What I found was only about fake controllers…

I have been googling, and then after a month I decided to ask for help. I will just look into the source code and see what might be the cause.

any joy getting fake ps3 controller to pair? Ive already spent a good few hrs trying. works under emustation via usb, but no BT. Under osmc BT it comes up as a device and when I pair without PIN it seems to say its connected but the controller keeps flashing and doesnt work.

I haven’t tried in awhile, but no I never got the bt to pair properly.

hmm ok bit weird as it almost seems to pair under osmc in kodi- although controls dont work on ps3 controller. the pl 1 light comes on like its paired. works fine connect via usb in emu station

Hey, guys, I have a fake PS3 controller from Gasia… I have managed to get it working on Kodi Leia (v18). Here’s how I did it:

SSH into your OSMC installation. Then…


sudo nano /etc/apt/sources.list
(add the following line in the very first line of the file)
deb Index of /osmc/osmc/download/dev/gmc-18 gmc-18 main
(to save the file, press CTRL+O, ENTER, CTRL+X)
wget -qO - | sudo apt-key add -
sudo apt-get update
sudo apt-get dist-upgrade
dpkg -l | grep mediacenter-osmc | awk ‘{ print $3 }’
(the last command should show OSMC version 17, which has KODI version 18)


cd /home/osmc
wget .
chmod +x

Go to “manage packages” > drivers > ps3controller > install from source (wait) > configuration/options > install ps3 controller (clone support gasia) > pair ps3 controller (clone support gasia) (follow instructions) > Then “connect controller through usb”, then disconnect usb, and pair via bluetooth… It may not pair yet.


apt-get install rfkill
rfkill unblock all
hciconfig hci0 up


sudo su
echo ‘SUBSYSTEM==“input”,ACTION==“remove”,RUN+=“/bin/systemctl restart sixad”’ >> /etc/udev/rules.d/999-sixad.rules
sudo udevadm control --reload-rules && udevadm trigger
sed -i ‘s/exit 0//bin/systemctl restart sixad\nexit 0/g’ /etc/rc.local


From the Kodi 18 (Leia) main menu, click on the Add-ons icon (open box icon). Select Install From Repository, Click on the Kodi Add-on, Repository, Click on Game Add-ons, Select Emulators, From the giant list of emulators you now see, you have to install the ones you wish to use. If you can’t find the “Emulators” section, some distros don’t compile them. The script (above) may have some hidden menus to download and install all cores (emulators) in one shot. Give it a try. Also, check under kodi settings “my addons” to see if you don’t already have all the emulators installed.

Now, install some other game addon (research about your options!) which uses “Kodi retroplayer” to launch games. It will require some emulators addons (also called libreto cores) to have been downloaded and installed already on kodi.

You know that RetrOSMC is not needed for gaming with Leia v18, right?

Yes, I know RetrOSMC is not needed for gaming with Leia v18, but it is needed in order to install fake PS3 controller drivers (from Gasia).