Cant connect SSH into rasp OSMC

Hey,

I have just installaed OSMC on my new rasp 3+. Then i have configurated WIFI and im now trying to connect with putty /SSH. I get the error “Connection time out”

Then i tried troubleshooting, i checked that SSH is enabled in rasp pi, and doublechecked that the IP is correct.

I have tried to browse through the other related post’s but didnt find it helpfull.

Do you have any ideas we can try out?`

Best regards

//Slebo

Latest version of putty? Which OS?

Maybe try to go to console on OSMC to check journalctl

Hey, its Win 10 and regarding putty its “Release 0.70”

How do i run commands directly on OSMC ? then i found this that i could try:

sudo nano /etc/ssh/sshd_config
and add: IPQoS cs0 cs0

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

haha yea, by the same time i made that post i found the guide when i was searching the whole web. anyways i entered the code, but sadly didnt help. I still cant connect with Putty / ssh :-/

do u have any other ideas?

Which code?
When you have command line open run sudo journalctl -f and check if you see your ssh connection coming in.
If not provide logs via grab-logs -A and provide URL here

Okay i typed it in, but im not sure what to look for, so i posted picture here.

Now im starting to think its not properly connected to the internet. when i open cmd on my computer and ping 192.168.1.13, it dosnt get any ping returned. but after looking in the attached photo, it shows that it is connected and that it has an ip adress ?

btw dont mind the dust on the screen :stuck_out_tongue:

I just tried to reconnect to the wifi, somehow it cant only find the 5G spot and not 2.4G spot, its the same router so shouldnt make a difference ? im using the 5G spot.

Okay just to round up. The problem is not with the rasperry pi, its somehow my router.

I have netgear Nighthawk R7000, and raspberry Pi isnt showing up under the list of attached devices, even though its online using the wireless internet. I have verified this by runnin the ifconfig command on the raspberry Pi.

So problem is, how can my raspberry pi be connected to the internet, but aint showing up on my router? which i assume is why i cant ping to it.

Do you have separate names for the 2.4 and 5G networks? (I think the R7000 defaults to this and calls the 5G network .media) If it’s setup to have both 2.4 and % networks as one name that may be causing your problem, so try separating the networks to see if that helps.

reinstalling the previous update on my router helped and its now working! :smiley:

1 Like