Can't connect to bluetooth speaker - OSMC on Raspberry Pi Zero W

Hey. I can’t connect to BT speaker. In MyOSMC → Network, when I choose my device, it says “Connection to XYZ failed”. When I follow this: Connecting Bluetooth on Pi W in terminal - Raspberry Pi Forums, and try “connect ”, I get: “Attempting to connect to 30:22:00:08:13:3F
Failed to connect: org.bluez.Error.Failed”. Help! :frowning:

Did you install the a2dp package?

I will try! Just “sudo apt-get install a2dp”?

Edit: Error: Unable to locate package.

Installed, rebooted, tried and nothing changed. Still the same errors.

Which Bluetooth Dongle are you using?
Have you tried with bluetoothctl to remove the device again first?
After that run bluetoothctl without sudo and do agent on / scan on / pair / trust / connect

Removed device, paired etc., but error is still the same. I’m using built-in bluetooth chip.

Not so sure about the Pi Zero as I only have a Pi 3 with which it works.
Maybe try on a fresh raspbian if it works there

Went from Raspbian to OSMC. On Raspbian all works, and BT speaker is playing sound only when playing in VLC. I wanted to play sound on BT speaker in Kodi too, so I went to OSMC.

Upload logs grab-logs -A maybe someone sees any issue


That is a bit strange
Mar 08 14:33:28 OSMC bluetoothd[408]: a2dp-sink profile connect failed for 30:22:00:08:13:3F: Protocol not available

Now OSMC connects to my speaker, but still no sound. I tried nothing to fix connection and pairing problems - just tried again. No bluetooth option in System → Sound Device. Logs:

Info about my device:
[99E-S10]# info
Device 30:22:00:08:13:3F
Name: 99E-S10
Alias: 99E-S10
Class: 0x240408
Icon: audio-card
Paired: yes
Trusted: yes
Blocked: no
Connected: yes
LegacyPairing: no
UUID: Headset (00001108-0000-1000-8000-00805f9b34fb)
UUID: Audio Sink (0000110b-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control (0000110e-0000-1000-8000-00805f9b34fb)
UUID: Handsfree (0000111e-0000-1000-8000-00805f9b34fb)

Check this thread

I don’t see any BT device here:
osmc@OSMC:~$ pactl list sources short
1 alsa_output.platform-soc_audio.analog-stereo.monitor module-alsa-card.c s16le 2ch 44100Hz IDLE

That is after the device is paired and connected?
You clear would need to have at least one bluez device in there.

Yeah, I have paired and connected BT speaker. I can even pause songs and skip by buttons on speaker, but no still no sound. :confused:

Then I am out of ideas. Maybe the multi function of the speaker confuses OSMC

Do we have the make and model of the speaker?