Cant connect to kodi repository

Hi all,

Im setting up my vero v but can’t connect to kodis own repository, if i try and install a zip it won’t install the dependencies. I’m getting 770 Mbit down using speedtest cli so I know im connected. Weird one



Hard to say without logs.

Have you tried rebooting and trying again?


Go to settings>add-ons> and then open the side menu and select the check for updates option.

Ive done updates and got the august one, also did a cli update, its quite odd

Ok weird, I installed pip and things seem to be going again.

Won’t be related.

Likewise. As the Kodi repository is a bit different.

Could just be this stupid vodafone router, still getting 780 down 110 up on ethernet, a lot better than i get on other devices.

Ive also had another problem true hd atmos was fine on my sonos setup, paused, resumed several times but as soon as screensaver dimmed couldn’t get atmos again. Dont know if its a known problem or upline kodi thing as I believe ffmpeg is causing issues? Anyway thought id mention it if it’s not been noticed.

To the best of my knowledge this is not a known problem so I would suggest to start a new thread about it with some debug logs where the issue has been reproduced.

Got it, had to disable enable dolby digital transcoding. Must have enabled it while messing about adjusting stuff during the film. Now picture and sound is awesome and this was streaming a 100Gb 2 hour remux for those wondering on speed. I never had gb fibre while I had my 4k+ but my odroid c4 sometimes struggled. Impressed Sam worth every penny. Oh and reboot times are amazing, usually id now add lots of services but gonna keep them on the c4 and keep this beast lean and mean. Till tomorrow maybe we all like to tinker or wouldn’t be here eh :thinking::wink:


Glad you’re enjoying it. I’d install what you want and see how it goes. Worst case you earn yourself a reinstall.

1 Like

I will do but probably keep my emby server on the c4 and it uses syncthing for offsite backup which can be intensive while hashing. Its cool in my upstairs lounge (reappointed bedroom). I’ll probably make it my tailscale access point. I’ll remember more as i go. Any suggestions?

Also any plans for custom cases, i always worry about overheating, my antec pc case with 200m top fan and several others attests to that. Now all it does is my tax return :joy:

Custom case won’t be necessary. If the device gets too hot – it’ll shut itself off.

But you shouldn’t hit this – even with the weather we are currently having.

Can it do mine too?

It dont do mine without sifting through hundreds of papers and emails but as a physics graduate i refuse have some accountant do it. Not yet anyway but did just hand off 5k to someone else, comes a point youve got to delegate as im sure you’re well aware. Concentrate on the core business and make time for yourself.

1 Like

Mark, I’m having the same issue with my Vero V that I just unboxed. Did you get it resolved? If so, how?

It would seem that it updated the repository on its own which I think happens once per day. This can be forced by going to settings>add-ons> and then open the side menu and select the check for updates option.

Tried that. No effect.

Manually installed the PlexKodiConnect repo using the zip file method. It gives same “cannot connect to repository” results.

There might be a problem with the mirror again. This is something @sam_nazarko would need to look into. Sorry for the inconvenience.

1 Like

Please try now.

This is an upstream Mirrorbits bug and I have manually resolved things.

I will think of a fix / mitigation shortly.



1 Like