Can't connect to official Kodi repository after clean install 19.1


After updating to the latest OSMC on my Vero 4K I was running into a lot of error messages, probably just junk from years of happy usage finally rearing its head.

I performed a clean install of OSMC. Everything seems fine, except I can’t install anything from the official Kodi add-on repository. It just returns an error message: “Could not connect to repository.” whenever I try to open it via the addons menu.

As it’s a totally fresh install I’m kinda at a loss here. Internet’s working fine. Any ideas?

Here are my logs:

I also have the same issue on a fresh, latest, fully updated install on my vero 4k+. If i go to addons > install from repo i get “could not connect to repository” and then the interface crashes.

OSMC 2021.08-1

build 19.1.0
git 20210803-osmc

I’ve just installed OSMC 2021.01-8 at PI4 (clean install only).
I cannot connect tho Kodi Repository too. Trying to add some addon with “Install from repository” only “reports cannot connect to repository”

Any idea?
Is there a general probelm with Kodis repository?

Internetconnection seesm to be OK as an Updatecheck insode myOSMC did several updates without any error message


I tried to install Tubed (this URL is from my logs: Failed with 503 error. Same url doesn’t work in my browser too. Is the repository down?

Some here - any access to… reports 503.
Using OSMC installer also states connection problems.

I guess theres some trouble with OSMC access.
4But I do not understand, that accessing the official kodi repository after a clean install alos reports access errors? Is the official kodi repository access routed through some OSMC server ?

The update system seems to be down:

1 Like

There were some issues with the update server earlier. This should now be solved.

I can confirm - access is possible now