Cant connect to OSMC from other device (Kore, Samba, PuTTy)

Hello, I have OSMC installed in the Raspberry with Kodi installed and have a problem. When I turn on the Raspberry I can connect, without problems, by SSH or using the app Kore to move by Kodi or use transmission, but after a few seconds (the minute at most) stop all these services and I can not connect. I have to say that the Internet works because I connect to Internet but I can not use the services of Kodi I mentioned earlier for example …

Thank you and hoping help!

Edit:

Logs are here: http://paste.osmc.io/rilofigiti.vhdl4

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

Hi,

Here are more details.

I’m using OSMC installed in Raspberry Pi 2. I’m using the last OSMC version (October 2016) and here are the logs:
http://paste.osmc.io/rilofigiti.vhdl

Please I need help with this…

How do you provide power to the raspberry pi and how is the wifi dongle connected? Have you enabled usb_max_current? Does any other device on your network use 192.168.0.27?

Hi,

I have a power suply of 2A. And the wifi dongle is conected to a powered hub. The IP 192.168.0.27 is only for Raspberry.

Thank you for your help…

Can you try enabling this in MyOSMC followed by a reboot?

Yes, it is enabled. And the problem persist.
Its randomly, cause the system and services works fine but without any reason the services like Kore, SSH or anything does not work…

Looks like a plain wifi/DHCP issue

Nov 03 00:53:06 osmc connmand[287]: wlan0 {newlink} index 3 operstate 2
Nov 03 00:53:06 osmc wpa_supplicant[368]: wlan0: CTRL-EVENT-DISCONNECTED bssid=80:3f:5d:83:a6:b3 reason=3
Nov 03 00:53:06 osmc avahi-daemon[259]: Withdrawing address record for 192.168.0.27 on wlan0.

Tell me more…I dont have any idea about it…

Thank you!

Your wifi is diconnecting, although it is not clear why just from the logs.

Does the wifi dongle work in another machine ok?

Can you reconnect the network from the MyOSMC menu?

The wifi works fine because I’m using Internet for example to watch online media or live TV. But I cant connect to Rasberry from other devices like using Kore App from Android or PuTTy from Windows.

Hello,
I’m experiencing a similar problem: sometimes wifi is not connecting at boot time or it connects but disconnects randomly. The problem doesn’t seem to be related with October update (I first had the problem before that update). Can’t reconnect using myOSMC.

Here is my log file: http://paste.osmc.io/ebiqejaruy.vhdl

My configuration:
Raspberry pi 2, Kingston 16 GB microSD (Class 10), 2.5" HDD (2 TB) directily connected via USB and a 2.5 A PSU. The wifi dongle is a TP-LINK WN823N Nano.

The PSU is ok and the the wifi dongle works ok in Windows 7. The wifi router is a TP-LINK WN8951ND and works fine with my windows 7 notebooks.

I have to say that I’ve never experienced disconnections and/or any wifi problem with this Wifi dongle and OSMC.

UPDATE: the problem persists with a fresh OSMC install (tried with another uSD card).

Any hint?

Kranz

Your log file clearly shows the wifi disconnecting and the IP address being withdrawn.

I suspect that either you are using an unsupported dongle, it is faulty or underpowered.

Underpowered PSU is most likely issue.

How have you verified this?

Since the latest OSMC update, max USB current is enabled by default, which will cause a further strain on PSUs. Also – if you’re using an 8192CU based adapter (check with lsmod), it will consume more power as I have disabled power saving in favour of better performance.

Make sure you are using a good power supply.

@sam_nazarko

I’ve checked my PSU with a digital voltmeter using the testpoints located under the board.
Test conditions: Rpi2 playing a full hd movie, amule on and downloading/uploading with temp directory on the USB HDD) and I found 5.04 V and 4.96 V, so I think the power supply is ok. Maybe a ripple problem but I do not have a scope at this time. The strange thing is that if I try to reconnect using myOSMC the dongle won’t reconnect to the network, even if I reboot the Rpi. The disconnectons started some days before the October update.
The only relevant thing I did was a firmware update to the wifi router (TP-LINK WN8951ND) to fix some bugs, but I have no problems with other devices connected to the network (laptops and a smartphone).

At this point I suspect that the wifi USB dongle is being faulty.

Thank you for the help :slight_smile:

Kranz

In my case, is not problem of PSU cause I have tried with two PSU and the problem persist.
And the wifi dongle works perfectly because I have used it in a laptop and works, and for example:

While I am watching a online movie (using dongle and Internet) i cant connect to raspberry and OSMC with my Android phone and Kore app.

Thank yoy everybody…I am still looking for a solution.

This would indicate that your power supply is either failing or not up to the job.

The Pi requires a low ripple constant minimum voltage of 5v. If your supply is dropping below 5v under load as your test indicates then you will see issues, especially in a power hungry setup like OSMC.

It would appear that you don’t have sufficient power to keep your Pi running, your dongle running and your network connected while everything is under load.

Maybe your router’s new firmware is not as tolerant of connections that appear to flake out? You could try rolling it back to see if the problem went away.

Maybe you don’t have sufficient bandwidth available on your dongle whilst streaming to make external connections?

Hi,

Anyone can help me? The issue persist…I have tested with LibreELEC and works fine. But with OSMC not… Help

I cant connect by PuTTy, or SMB, or Kore…I cant find my rasberry from other device…But it is connecg to my network cause I can view online tv’s or movie’s using any addon or any other pluggin.

I have psu of 2A and powered hub where I connect hdd and usb doongle.

Anyone can help me?